Dansguardian não inicia corretamente…



  • Toda vez que reinicio o PC/SO, o Dansguardian não incia.
    Descobri que após alteração do arquivo dansguardian.inc em /usr/pbi/dansguardian-i386/etc/dansguardian, retorna ao conteúdo original após o "reboot".

    Mensagem de erro:

    [2.1-RC1][root@pfsense]/(1): dansguardian start
    Error opening/creating log file. (check ownership and access rights).
    I am running as clamav and I am trying to open /var/log/dansguardian/access.log
    
    

    O que eu tenho que alterar manualmente no arquivo "dansguardian.inc" é o seguinte nas seguintes linhas:

    • linhas…
    daemonuser = 'havp' -> 'nobody'
    daemongroup = 'nobody' -> sem alteração
    
    
    • linhas…
    loglocation = '/var/dansguardian/log'
    statlocation ='/var/dansguardian/log/stats'
    
    

    Após estas modificações manuais, o dg "starta" normalmente.

    A pergunta é: Por que o sistema dá um "reset" e volta os valores "default" toda vez que reinicio o PC?

    Pra mim é um problema, pois se eu não estiver por aqui numa queda de luz que o nobreak não consiga segurar, ninguém vai saber colocar no ar o firewall novamente.

    Versão em uso:

    2.1-RC1 (i386)
    built on Wed Aug 21 01:29:42 EDT 2013
    FreeBSD 8.3-RELEASE-p9
    You are on the latest version.
    
    


  • Se você tem tempo e existam vagas:
    http://forum.pfsense.org/index.php/topic,65669.msg359344.html#msg359344

    Inscreva-se. Vale cada centavo e cada minuto.  ;)

    Quem sabe este hangout lhe ajude a resolver alguns problemas?



  • @johnnybe:

    Se você tem tempo e existam vagas:
    http://forum.pfsense.org/index.php/topic,65669.msg359344.html#msg359344

    Inscreva-se. Vale cada centavo e cada minuto.  ;)

    Quem sabe este hangout lhe ajude a resolver alguns problemas?

    Poxa vida… só agora, 21:11, vi a mensagem e estou de saída! uma pena!
    Mas, valeu pela dica.
    Se estiver disponível, depois vou assistir "offline"!

    Abraço.



  • @johnnybe:

    Se você tem tempo e existam vagas:
    http://forum.pfsense.org/index.php/topic,65669.msg359344.html#msg359344

    Inscreva-se. Vale cada centavo e cada minuto.  ;)

    Quem sabe este hangout lhe ajude a resolver alguns problemas?

    Agora consegui instalar normalmente tanto a versão 2.0.3 quanto a versão 2.1-RC2, sem mexer em nada de especial, apenas no modo "next…next...finsh".
    Vou tentar restaurar o backup ajustar detalhes de configuração pra ver se vai ficar tudo normal, depois volto a postar as novas impressões!
    valeu.