Can't get FreeDOS serial coms working on a Watchguard Firebox X750e



  • I'm able to watch the standard Watchguard OS boot on the console using a null modem cable at 115200 baud, yet when I boot FreeDOS I get the three beeps (I can change the number by editing autoexec.bat), but no console output at any baud rate.

    Any idea why this might be? FreeDOS is clearly booting, but the console simply isn't playing ball.

    The BIOS is marked:

    Filename:
    FWG550C
    CK:6B6C
    7/25/2008

    The box came with a 512M CF card, so I've been booting FreeDOS from a 16M card I had lying around.

    Any help much appreciated.

    Thanks,

    Steve



  • Ah, I think I've found it!

    http://doc.pfsense.org/index.php/PfSense_on_Watchguard_Firebox#Not_All_Null_Modem_Cables_are_Created_Equal.21

    Apparently the Watchguard OS works fine with just a simple 3 wire cable with Tx/Rx swapped, but FreeDOS required the hardware handshaking to be connected!

    Steve


  • Netgate Administrator

    Good to see you found the problem.  :)
    You have a newer bios date than any of my boxes. Other users have also reported that labelling but found the actual bios code to be identical. Still if you run biosid from the FreeDOS card and it's different to the output in the wiki we'd very much like a copy of it!

    Steve



  • Apparently nothing new to see here!

    C:\BIOS>biosid
            �������������������������������������������������������Ŀ
            �       BIOSID v1.1 - BIOS Identification Utility       �
            �       Copyright (c) 1998 Unicore Software, Inc.       �
            �       Tel : 1-800-800-BIOS                            �
            �       http: //www.unicore.com/                        �
            ���������������������������������������������������������
    BIOS DATE  : 12/21/2005CHIPSET ID : AlvisoBIOS ID    : 6A79GAKAC-00BIOS TYPE  : Phoenix Technologies, Ltd.OEM INFO   : **** BIOS Ver.ETAC0017 (2005/12/21> ****
    
            Press Any key to exit!
    
    

    Steve


  • Netgate Administrator

    Damn. Ah well, thanks for checking.  :)
    Still seems odd that they changed the date and code but nothing internally, like we're missing something.

    Steve


Log in to reply