RFC2136 Problem



  • Hi,

    I,ve trying the RFC2136 Updates on two pfSense 2.1 Instances with different two bind9 DNS Servers  and two different Domains. I do Script based  Updates to the Zones under Linux with nsupdate, which works, but under pfSense I didn`t even get a Notice on the Nameserver side.

    What I tried so far.

    Current pfSense version: 2.1-RC1 Built On: Mon Aug 26 16:50:31 EDT 2013
    Filled in:
    Enabled: yes
    Interface: WAN
    Hostname: sub.domain.com
    TTL: 300
    Keyname: sub.domain.com
    Key type: Host
    Key: TheHashKey
    Server: IP of the Bind9 Server (Documentation only talks about SERVER here, think this should be the DNS-Server to be updated)
    Use Public IP: Tried both here

    Cached IP shows the correct current external IP.

    Tried it with two different Domains on two different Bind Servers, which works if I use my Script with nsupdate.
    Got an E-Mail Notification from pfSense with the following Content:
    DynDNS updated IP Address (A) for sub.domain.com on WAN (pppoe0) to $CorrectExternalIP
    Nothing happend in the Bind-Server Logfiles.
    pfSense Logs print:
    php: /services_rfc2136_edit.php: Message sent to server@domain.de OK
    php: /services_rfc2136_edit.php: phpDynDNS: updating cache file /conf/dyndns_wan_rfc2136_'sub.domain.de'_$CorrectDNS-ServerIP.cache: $CorrectExternalIPofPfSense

    I tried to follow the Scripts for the DNS-Update but didn`t get a clue.

    How can i get more Information what is going wrong here?

    THX

    Daniel


  • Rebel Alliance Developer Netgate

    I split this topic because it was a new issue unrelated to the other thread.

    You might try sniffing some packets on the WAN when it claims to be updating.

    It's possible that the packets are trying to go out but not actually making it to the DNS server.

    Since fixing this, I have setup RFC2136 on close to two dozen firewalls and VMs and they all work well.


Log in to reply