Package Manager: Unable to communicate with www.pfsense.com



  • Hi, i wanted a better quality router and i installed pfsense 2.1-RC1 (amd64) NanoBSD 4g built on Wed Aug 28 and every works ok except when i tried to see what packages are available for this build and i came across the follwing error"
    "Unable to communicate with www.pfsense.com. Please verify DNS and interface configuration, and that pfSense has functional Internet connectivity."

    i did the following troubleshooting on the shell prompt

    tested if i can ping

    
    ping www.pfsense.com
    
    PING www.pfsense.org (192.207.126.26): 56 data bytes
    64 bytes from 192.207.126.26: icmp_seq=0 ttl=48 time=179.622 ms
    
    

    tested if i get dns info

    
    dig www.pfsense.com
    
    ; <<>> DiG 9.6.-ESV-R5-P1 <<>> pfsense.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16137
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;pfsense.com.                   IN      A
    
    ;; ANSWER SECTION:
    pfsense.com.            300     IN      CNAME   pfsense.org.
    pfsense.org.            300     IN      A       192.207.126.26
    
    ;; Query time: 253 msec
    ;; SERVER: 195.170.0.1#53(195.170.0.1)
    ;; WHEN: Fri Aug 30 17:57:07 2013
    ;; MSG SIZE  rcvd: 70
    
    

    i tried to get something

    
    fetch -o /tmp/test http://www.pfsense.com
    
    (after 90seconds of waiting/timeout)
    
    /tmp/test                                     100% of   13 kB   41 kBps
    
    but
    
    fetch -o /tmp/test http://192.207.126.26/
    
    (1 second delay)
    
    /tmp/test                                     100% of   13 kB   40 kBps
    
    some more fetches
    
    fetch -o /tmp/test http://www.google.com/
    
    (30 seconds delay)
    
    fetch -o /tmp/test http://www.otenet.gr (my provider)
    
    (instant)
    
    

    my connection is pppoe and ive set mtu 1492 and mss 1452

    i still cant figure out how to solve this problem, any hints?

    EDIT:

    tried diagnostics-> nslookup , it takes 30 seconds to bring back result

    running it from prompt is instant


  • Netgate Administrator

    You seem to be mixing .org and .com in your tests. I assume you tried both?

    Steve



  • I didnt mix anything, pfense.org and pfsense.org are the same, if i try and ping pfsense.com it resolves to pfsense.org


  • Banned

    Another guy with messed up IPv6 connectivity?

    
    env ip6addrctl_enable="yes" ip6addrctl_policy="prefer_ipv4" /etc/rc.d/ip6addrctl start
    
    


  • it seems so, running the command fixed the problem. The thing is, i didnt mess up with any setting so could it be that the default settings dont work out of the box? my isp has dual stack but i dont see any ipv6 address anywhere. i guess it will be fixed it a future update. thank you very much for your reply


  • Banned

    Well, not really possible to help without knowing how does the ISP "ship" the IPv6 connectivity to customers. Usually documented somewhere on their web.



  • i did some search on how my isp servers ipv6 and i found some info for a router zte w300 if it suggests
    For WAN
    DHCP  IPv6 Mode: SLAAC
    DHCP PD: Enable
    MLD Proxy: Disable

    For LAN
    Radvd Enable: Enable
    Radvd mode: Auto
    DHCP6 server: enable
    DHCP6 mode: auto


Log in to reply