Phase 2 Mobile Client Local Network Type LAN Subnet No Internet Access

  • I have IPSec setup and working on my iPhone but according to the tutorials everyone on Phase 2 sets the Local Network Type to LAN Subnet and if I do this I get no network/internet access.  I found somewhere that someone said to set it at Type: None I tried this and all is working as it should.  My question is why doesn't it work when set to LAN subnet?  What is the difference performance or security wise if set to None where it works?


  • anyone?

  • Does anyone use IPSec? lol  I do have OpenVPN setup as well but figured i might like to have an IPSec server going as another option should the need arise.

  • I just followed this guide about 15mins ago and mine is working, however I'm getting ready to upgrade to 2.1

  • Same issue here and I followed the guide.  I can connect via my phone but I get no local network access or internet.  Confused  ???

  • Fixed my issue, it was a NAT issue with my addressing scheme.

  • @Rubicon:

    Fixed my issue, it was a NAT issue with my addressing scheme.

    Can you please share what you have done to solve the problem ? I am having the same problem here, and all the tutorials, examples and faq's won't help me out.
    Thanks !

  • Been working some days on setting up the pfsense 2.1 ipsec and failed fataly.

    I got what ussually is considered the hard part i freebsd working with the esp protocol and communication between the to pfsense 2.1 units showing tunnel up.

    But if you check the routes there are no routes set and if you go to the command prompt and check the ifconfig there is no gateway interface setup.

    So after thinking I done it wrong and tried over and over to set it up with same result.

    I did as such.
    I made the gateway interface and set the settings to it and it started talking over the esp tunnel.


    I did as follows if someone wants to do this:

    gateway 1 (corp):

    ifconfig gif0 create
    ifconfig gif0 internalcorp_ip internalpriv_ip
    ifconfig gif0 tunnel externalcorp_ip externalpriv_ip

    gateway 2 (priv):
    ifconfig gif0 create
    ifconfig gif0 internalpriv_ip internalcorp_ip
    ifconfig gif0 tunnel externalpriv_ip externalcorp_ip

  • I was NATing the wrong IP.  I use a secondary public IP as a virtual IP address in PFSense.  Had to setup a manual outbound NAT for my IPSEC IP's.  So if my IPSEC LAN IP's are then I need to setup an outbound NAT for to my public IP x.x.x.x.  Once setup I had internet.

Log in to reply