Multi Wan load balancing and failover not working



  • Hi,

    I have two wan's configured. one is 2 Mbps leased line configured with static IP and the other is a 8 Mbps DSL line configured with DHCP. I've setup squid and squidguard for proxy (Squid running on non-transparent mode). I have created a WPAD file for automatic proxy detection in the network (WPAD file hosted on a different Linux web server) and i have also put a firewall rule to block port 80 and 443 on top of the firewall table to block users from bypassing proxy. other packages installed are: lightsquid, sarg, bandwidthd.
    I've setup a gateway group with both the  wan's in the same tier, and selected the gateway group in the firewall lan rule.
    The problem here is: only the gateway which is selected as default under routing is being utilized and the other wan is not being used at all. If i swap the default gateway, the usage also is swapped.

    please help me with this.


  • Rebel Alliance

    Search at this forum section: http://forum.pfsense.org/index.php/board,21.0.html

    There are some threads about squid & multi wan



  • Hi thanks for replying..

    I've gone through many threads about squid & multi wan.. everyone say to add a floating rule and add "tcp_outgoing_address 127.0.0.1" in squid custom options (I've already done that). But i'm still facing the same issue.. Please help!!

    For adding more information.. i'm currently using pfsense version 2.1-RC0 (i386).



Log in to reply