Manual outbound NAT VIP CARP issues



  • Hi, I've seen there are quite a few old discussions on this topic, but I am unable to find a complete solution…
    My issue is that with "Automatic outbound NAT" obviously the box that is primary at the time, it's WAN IP is returned by whatismyip.com as expected. All the discussions that I read, indicates that the solution is to use "Manual outbound rules" and point to the VIP WAN CARP. Unfortunately, for the life of me, I can not get it working. On manual, there is just no routing to the WAN GW at all and the clients can not reach the outside. DNS is still working for the clients. Using latest v2.0.3 and also tried 2.1RC. Please find attached my set-up. The 3 WAN IP's are public IP's provided by the data warehouse. On vsphere 5.1 with promiscuous allowed on the switch for the LAN and SYNC interfaces. So all the rules etc. syncs fine. 
    Thank you in advance.
    https://app.box.com/s/vy3txx0h6twa3vpbsek6



  • just try to help…

    1. First, make sure on single pfsense server, you can go out to internet....

    • enable automatic nat, removed all the static nat entries
    • configure you pc gateway point to 192.168.1.252
    • make sure your pfsense WAN have default gateway point to the router (i noticed your wan gateway is in different subnet ???)

    Make sure step 1 is successful before proceed to step 2

    2. repeat the above for the second pfsense server and point your pc gateway to 192.168.1.253

    3. Configure CARP... make pfsense server 1 Master on both LAN & WAN
    point your PC gateway to 192.168.1.254...it should work...


Log in to reply