POSTFIX - Multiple mail servers forwarding on Xenserver



  • Hi,

    Does anyone know how to go about setting up multiple mail servers behind pfsense?
    Is using postfix the right choice?
    Are there any good tutorials?

    Thank you for any assistance offered.



  • This is my setup on a Xenserver

    Only 1 fixed IP address is available and have got the reverse proxy and passive ftps working.

    Now, only have to get the mail servers for different domains working for the individual vps.



  • In Postfix, under the Domains tab, you can certainly enter different IPs for mail servers handling different domains.

    You just need a firewall rule on WAN to forward port 25 traffic to Postfix, rather than the mail server:

    ID 	Proto 	Source 	Port 	Destination 	Port 	      Gateway 	Queue 	Schedule 	Description
    
     	TCP 	* 	* 	WAN net 	25 (SMTP) 	* 	none 	  		SMTP to Postscreen  
    ```   
    
    Can't see why it wouldn't work for inbound.


  • Thanks for your reply biggsy :D

    Umm…..I have the firewall rule in place
    have the domains and their respective ips filled in
    reverse proxy points the domain to their correct servers (web is working fine)

    I can send but I am still not receiving mails

    uhmmmm






  • I'm getting a

    Relay access denied????




  • The relay access denied was fixed, was cause by mis entry of domain names

    Now that I can successfully receive emails I'm having problems sending from php

    AUTH error: 503 5.5.1 Error: authentication not enabled
    AUTHENTIFICATION error: 502 5.5.2 Error: command not recognized
    AUTHENTIFICATION error: 502 5.5.2 Error: command not recognized
    RCPT TO error: 550 5.7.1 : Helo command rejected: Host not found
    DATA error: 554 5.5.1 Error: no valid recipients
    DATA(end)error: 221 2.7.0 Error: I can break rules, too. Goodbye.
    QUIT error:



  • In the log status I get:

    RCPT from unknown[192.168.4.101]: 550 5.7.1 : Helo command rejected: Host not found


  • Banned

    Yes, you already identified that you have a problem with missing DNS records, so… the point is?



  • Add your internal hosts to my network field on acl. This may may prevent postfix from doing some tests.  But the best way to fix it is creating a complete smtp header with valid entries and corresponding dns setup.

    Smtp needs dns to work properly.



  • @doktornotor:

    Yes, you already identified that you have a problem with missing DNS records, so… the point is?

    The problem, which we solved with a PM or two, was that he accidentally entered fully qualified host names under the domains tab instead of just the domains. It wasn't a problem with DNS.


Log in to reply