Vlan working after reboot pfSense



  • Hello,
    I have a problems with VLAN's and pfSense.

    If the power went down for some reason and pfSense is booting up (when power is back), vlans sometimes doesn't work.
    pfSense then hangs on retrieving WAN IP address (during booting), when it timeout after ~1 minutes (?) I get the console setup, here I choose to restart the pfSense box.
    When this is done all connections and vlans are working fine again!

    Is there maybe a solution or a script that automatic fix this vlan problem?
    (maybe a script which check's the WAN ip address, when it's empty on boot restart for example the pfSense box?)


  • Netgate Administrator

    What NIC hardware are you using? What switch?

    Steve



  • and what pfense version? and how much memory?



  • I am running pfSense version 2.1:

    2.1-RELEASE (amd64)
    built on Wed Sep 11 18:17:48 EDT 2013
    FreeBSD 8.3-RELEASE-p11

    I have one switch and one router that handles the VLAN traffic.
    The switch is a Netgear GS108E and the router is a TL-WR1043ND running OpenWRT (Attitude Adjustment 12.09 final).
    pfSense has 2 Intel Gigabit CT Desktop Adapter NIC's.
    The NIC that handles VLAN traffic has been passtroughed to pfSense (for direct acces betwen pfSense and the NIC), the other one is a virtual adapter (vmxnet3) that handles all LAN traffic.

    pfSense is virtualized within VMware ESXi 5.5


  • Netgate Administrator

    You could removing any hardware VLAN feature in pfSense. Does the passthough NIC claim to support any, hw_vlan_tagging for example?

    You could move the VLAN handling to ESXi.

    Steve



  • My NIC supports VLAN
    (following to this site: http://www.intel.com/content/www/us/en/network-adapters/gigabit-network-adapters/gigabit-ct-desktop-adapter.html)

    You have also a good point to move VLAN to ESXi, I will try this!


  • Netgate Administrator

    I meant what does the interface report when you query if with ifconfig. Some cards have a problem with hardware vlan tagging, you can disable it on an interface (em0 here) like so:

    ifconfig emo -vlanhwtag
    

    If that works you can set it to run at boot using a cron job or with the Shellcmd package.

    Steve


Log in to reply