Updaters server VERY broken


  • Banned

    I tried to download a couple of nanobsd files from http://updates.pfsense.org/_updaters/ - every time the download NEVER ends, potentially filling up your entire drive - the file gets downloaded uncompressed (see below). Does NOT happen with latest.tgz from there. I stopped the first download after it grown to almost 2GiB.

    EDIT: For the broken img.gz files, this additional header is there:

    
    Content-Encoding => gzip
    
    

    Not there for .tgz ones, which can be downloaded correctly.

    EDIT: Well did let the latest-nanobsd-512mb.img.gz (file size 80,434,003) to download for a while, it finally gets finished but uncompressed - file size 229,630,464. (The first one I tried was latest-nanobsd-4g.img.gz so it's been probably almost finished when I killed it. Huh.



  • Something got messed up in the file sync, I blocked public access to updates and am fixing.



  • It's been fixed and is back up if you haven't noticed already.


Log in to reply