2.1 upgrade - root mount eror



  • I have 2.0.1 amd64 installed, tried upgrading to 2.1 RELEASE amd64, but after the upgrade I get ROOT MOUNT ERROR.
    I have no USB disks attached, I'm using a SATA drive.
    Intel motherborad with Intel Celeron G530, PS2 keyboard attached.
    I'm upgrading via the web interface, providing the tgz file manually.

    Tried changing the SATA drive, a reinstall of 2.0.1 and another upgrade attempt, but the same result.

    Typing ? at the loader prompt, returned the same "help" message which was shown before, making me think that pfSense 2.1 doesn't properly detect the SATA disk anymore.

    I'm guessing that pfSense 2.1 is seriously broken regarding Intel/SATA/AHCI.
    I'm going to test the upgrade out on another Intel machine tommorow just to be sure…



  • Have you tried downloading the update and manually updating it from your computer?

    I tried the auto update but it was hanging maybe too much people trying to get to the upgrade goodies.

    Upgrade went fine and on 2.1. Release.



  • Perhaps you missed my little edit just a minute before you posted:
    I'm upgrading via the web interface, providing the tgz file manually.

    Auto-update currently doesn't work at all. It fails to see, that 2.1 exists.


  • Rebel Alliance Developer Netgate

    If there is a problem, it may be with how it is detecting your particular controller. AHCI isn't enabled by default so if you can change that in your BIOS it may help.

    Otherwise, you can stop at a loader prompt from the boot menu and type "load ahci" and then "boot" and if it sees a disk that way, you may need to manually specify it at the mountroot prompt, then add a loader.conf.local line to load ahci at boot and manually edit /etc/fstab for the new disk name.

    We've run quite a lot of test installs and upgrades ourselves and others on the forum and our customers have also upgraded OK, this may be the first report I've seen where it actually failed to find a disk that was detected OK before.



  • Tried out the same procedure on an Intel DP35DP motherboard, with SATA/AHCI and no problems.
    So the original issue must be related to the specific motherboard.

    I'll try setting the disk to IDE instead of AHCI over the weekend to see if that will fix the problem. Before that I'll also try out the load ahci command as suggested, but I can't leave it at that, incase a future firmware upgrade decides to overwrite loader.conf and mess things up again…



  • The problematic motherboard is Intel DH61BE.

    I tried the "load ahci -> boot" commands, but that made no difference.
    Booting from a pfSense 2.1 x86 Live-CD gives the same error, only this time referencing the CD drive path as root mount error.

    Changing AHCI to IDE solved the issue.

    Still, there is obviously something messed up in pfSense 2.1 (or the underlying FreeBSD 8.3 atleast) regarding the bootup sequence - there are so many root mount error issues cropping up with different hardware…


  • Rebel Alliance Developer Netgate

    Part of the problem, I suspect, is that between FreeBSD 8.1 (pfSense 2.0.x) and FreeBSD 8.3, the IDE/ATA subsystem changed a little and it was able to detect more of the higher-end chips for dealing with things like AHCI than it was before, so it didn't fall back to the expected devices.

    I suspect that if the AHCI module was loaded, it may have actually found the disk, but it still may have needed some nudging because the disk name would have changed from adX to adaX.

    We have some ideas for handling this on 2.2 (see the ufslabels.sh script for a start) but it may need addressing sooner on some devices.



  • This was definitely an issue for me - had a new rollout and opted to use a new HP Pro tower.  Unfortunately it's at the office, so I can't look into which mobo, etc. right now.  Booted from the CD and tried install with the same results as the other posters.  Tried changing HDD settings in the BIOS from AHCI to IDE and received the same results.  Installed 2.0.3 and it worked great, upgraded to 2.1 and was left with an unbootable system.

    My answer, as of right now, is to stay on 2.0.3.  However, I will continue to monitor the forums for a possible fix.  I will just have to have a good backup before attempting the upgrade again.



  • @markoweb:

    The problematic motherboard is Intel DH61BE.

    Any chance you know which ports you are plugged into? the SATA 3 ports, or SATA 2?



  • Aah, very good question. That motherboard has the idiotic Marvell controller, which doesn't work even under windows.
    I don't know of the top of my head, which SATA ports I have used, but I would guess I connected the HDD to the SATA3 Marvell port…
    The following output perhaps confirms that? (mind you, I'm running in IDE mode at the moment)
    $ atacontrol list
    ATA channel 0:
        Master:  ad0 <hitachi hts542580k9sa00="" bbbzc3hp="">SATA revision 1.x
        Slave:      no device present
    ATA channel 1:
        Master:      no device present
        Slave:      no device present
    ATA channel 2:
        Master: acd0 <tsstcorp cddvdw="" sh-222ab="" sb01="">SATA revision 1.x
        Slave:      no device present
    ATA channel 3:
        Master:      no device present
        Slave:      no device present</tsstcorp></hitachi>


Log in to reply