Man. Upgrade to 2.1 nanoBSD causes in "out of swap space"



  • Hi,
    i tried the manual upgrade from my pfsense 2.0.3 nano(4GB)on ALIX 2d13 to the new 2.1. After the upgrade nothing works, no internet traffic, no weg gui from pfsense. SSH to pfsense ok. Restart web gui and access again. But no internet traffic. Reboot and it seemed to be working, but the igmpproxy wasn´t running. Start it causes in no web gui, no internet traffic, no ssh. Tried on console after power off/on, linux starts but then it gets these "errors":

    Anybody else this problem?? Perhaps anybody has a solution for this problem??

    kdk
    [Pfsense2.1 Fehler.txt](/public/imported_attachments/1/Pfsense2.1 Fehler.txt)


  • Banned

    Which packages you have installed?



  • and what base features do you use - e.g. how many VPN server and client instances of what types (OpenVPN, IPsec…)? VLANs? How many extra interfaces in addition to WAN+LAN?
    Yes, during bootup and interface down/up events the restarting of many things "all at once" can result in running out of memory and processes being "killed: out of swap space".
    Side note: It is FreeBSD underneath, not Linux.


  • Netgate Administrator

    My error was only similar, don't want to hi-jack the thread.  :)



  • No packages installed. OpenVPN Server runs. 3 active interfaces.

    EDIT: Sorry, now it is 2.0.3 running again without a package. It was the OpenVPN Client Export package installed, this is now gone.



  • Sounds similar our problem. We often ran out of RAM. Here how we solved it: http://forum.pfsense.org/index.php/topic,66617.0.html



  • A couple of things that may help with memory issues on the Alix platform are to disable logging and RRD graphing.



  • Hi,

    tried to Upgrade via auto upgarde, seemed to be working. Internet ok, IPTV ok. But Asterisk (behind pfsense) has double states, doesn´t work.
    I made a change and saved it -> that was it again -> nothing is going on, no Internet, no WebGui, no ssh, only ping response.

    Power off/on and changed bach to 2.0.3 and everything is fine due to another problem:
    https://redmine.pfsense.org/issues/1629



  • @individual-it:

    booting is now ok. But every change to the config by WebGui causes into a "crash or freeze", nothing is working.


Log in to reply