Altq with VGE Driver



  • Hello. I am Running Pfsense 1.2 RC3 Snapshot on a Captus Router. Dual CPU, 512 MB Ram, 512 CF Card but running the Full Version NOT the embedded. Anyway, for nics I have a Quad Port 10/100 Card that runs DC driver and a single port gigabit NIC (ZyXEL GN670) that runs the VGE driver.

    I am running dual cable modems and a dsl modem with load balancing for my WAN on the Quad card and my LAN is on the ZyXEL (VGE) gigabit card.

    I am trying to setup Traffic Shaping on the box but it gives me a ALTq error then I load the page. Saying that my card does not support altq. I know that the only card that could not support it is the gigabit Lan ZyXEL (VGE). Is there a way to check? Im fairly sure that it does support it. (I can run traffic shaping if I remove the card and run LAN through my quad card).

    Also I was wondering if anyone had any ideas for a good budget gigabit card that I could use if the gigabit card I have is deemed insufficient.
    I would like to get this working again soon.

    Thanks in advance



  • Traffic shaping with multi WAN isn't going to work properly at this time. It may be worked on during the hackathon, for 1.3.

    Running the full version on a CF card isn't recommended, the number of writes will kill the card pretty quickly.

    The VGE card is the one that doesn't support ALTQ. Supported cards listed here:
    http://www.freebsd.org/cgi/man.cgi?query=altq&apropos=0&sektion=0&manpath=FreeBSD+6.2-RELEASE&format=html

    Intel Pro/1000 "desktop" PCI cards are the cheapest quality cards you'll be able to find. Should be able to get one shipped for $30 USD or less.



  • Thanks a lot
    :)



  • I wasn't exactly the bearer of great news, but at least you know now.  :)



  • A little late, but have just bought an VIA Fanless thingy.

    I planned to use the internal NIC (vge) with an PCI Intel PRO/1000 (em).

    I was surprised that you have not patched the vge driver to support ALTQ!

    I have collected some links so you can read that ALTQ patch has been done and has found its way into the kernel driver. Hope you can patch the kernel too!

    If you need help for this, I will gladly help, but please help me by pushing me to the correct direction!

    http://blogs.freebsdish.org/brueffer/2007/05/21/news-from-the-altq4-front/
    http://www.iphouse.com/cgi-bin/man.cgi?altq+4 (For FreeBSD 6.2, look at date: May 12, 2007)
    http://people.freebsd.org/~bmah/relnotes/6-STABLE/relnotes-i386.txt (search for vge, first hit will tell you: "The vge(4) driver now supports altq(4).")

    My current installation:
    $ uname -a
    FreeBSD pfsense 6.2-RELEASE-p8 FreeBSD 6.2-RELEASE-p8 #0: Wed Nov  7 18:38:17 EST 2007     sullrich@builder6.pfsense.com:/usr/obj.pfSense/usr/src/sys/pfSense.6  i386

    I really hope you can patch the driver, or help me help the project :)

    Thanks for a great project!



  • Bump!

    In hope of any kind of feedback, will this be doable?
    I would love to come back to pfSense, but the lack of ALTQ support in VGE driver keeps me away :(

    Mamruoc



  • I will make sure that this goes in for 1.3 can you please open a ticket about this and assign it to me?!

    If you want to try it with pfSense 1.2 edit /etc/inc/interfaces.inc and add to the list vge.

    Hope it helps.



  • To be sure…

    Editing the file will make vge with altq patch available?

    The vge driver works fine but the QoS is not supported.



  • It will only allow the gui to treat the vge interface as alq compatible interface and not throw a warning when you run the shaper. You still need a vge driver version that supports altq.



  • Ok,

    Need the QoS so I guess I'll have to wait for 1.3 Beta 1…

    Any timeline for that release... hope

    Mamruoc



  • We just released 1.2 last night/today so you shouldn't ask for a 1.3 beta yet ;-)



  • Hihi, congrats!
    I was a very happy pfSense user until I bought a fanless VIA mini-itx chipset.

    I'm using zeroshell right now, but can't wait coming back to pfSense with QoS support.



  • 1.3 beta will be coming very very soon.  Keep your eyes peeled.



  • I second you on this request.

    @mamruoc:

    Bump!

    In hope of any kind of feedback, will this be doable?
    I would love to come back to pfSense, but the lack of ALTQ support in VGE driver keeps me away :(

    Mamruoc



  • @VincentV:

    I second you on this request.

    Good!  You can also be one of our guinea pigs :)



  • I see the 1.2.1 RC1 is released.
    Seems like you guys have moved on to FreeBSD 7.0.

    Does that mean that the vge driver now have ALTQ support?

    Mamruoc



  • @mamruoc:

    I see the 1.2.1 RC1 is released.
    Seems like you guys have moved on to FreeBSD 7.0.

    Does that mean that the vge driver now have ALTQ support?

    Yes.



  • Ah… finally!  :D

    Thanks alot!



  • Hmrf,

    I gave pfSense 1.2.1 RC2 a shot.
    My Intel Pro Gt 1000 was detected just fine as an em0 device, but the internal VIA gigabit nic was detected but NOT enabled:

    vge0: <via networking="" gigabit="" ethernet="">port 0xf800-0xf8ff mem 0xfdffe000-0xfdffe0ff irq 18 at device 14.0 on pci0
    vge0: MII read timed out
    vge0: failed to start MII autopoll
    vge0: MII without any phy!
    device_attach: vge0 attach returned 6

    So, what to do next?

    PS: Filled a ticket: http://cvstrac.pfsense.org/tktview?tn=1834</via>


Log in to reply