Thanks for the utterly broken 2.1 update.



  • It does not work at all on a soekris 6501-70. I did a clean install and none of the interfaces work, they all loose their setups after a reboot.
    Upgrading didn't work either. Same/similar problem.

    Going back to 2.0.3


  • Banned

    Similar rant with zero information will certainly NOT get anything fixed. Normally people test things, have a backup before upgrade and save and provide logs and other information useful for debugging and fixing the issue (if any).



  • http://soekris.com/products/net6501/net6501-70-board.html

    I wonder what its using for SSD/HDD/CF CARD or whatever?

    Why would it lose settings after a reboot?  Were the settings saved in a RAM disk or something?



  • None that I could see. Since I couldn't access my device anymore. After some fiddling I realised that setting up/resetting the NIC's wasn't going to work I did a clean install. Which booted fine, until I set up the interfaces which didn't work. So I rebooted, thinking that may reload some drivers or whatever to make the config I just made stick. And all IPs were gone again and the Soekris unreachable.

    I don't know how to read out the logs if I can't access the computer.
    Since I don't have time to spend hours on this I'm downgrading.
    And yes I did a config backup before hand ;)

    @keijianshi: I use a WD Black 2.5 250GB on Sata1 (on the board)



  • Not to bug you with what is probably a silly question, but what kind of install are you running?  Full or something like nano?  (I'd expect nano - but thats a lota ram and a big drive)



  • Its a Soekris 6501-70 in a rackmount (I have 2, one is currently down due to the update)

    The HDD's were cheaper than a 30GB SSD or something similar so I went with those, also keeping in mind the limited read/writes on SSDs. But yeah, theres only a 4Gb partition for pfSense. Otherwise the disks are empty.

    I run the embedded version on it as that seemed to run more low key for the hardware. Not sure if Full version is better but I assumed it's for more full featured PC's. So I went with embedded.



  • Ummmmm - On your system, while you are chilling - Why not try the full install.

    Then just stay out of the web gui most of the time.  As an experiment it would be interesting to see what happens.

    I'm betting it will boot right up and run.

    In the end, embedded version seems like it might be better?  Maybe?  I'm not sure how much overhead a web gui adds to the system when you aren't using it and don't have a bunch of graphs running.  i bet its not much.  I think mainly memory is the issue for embedded systems but 2GB is what you have right?  Thats seems plenty.

    I think the primary advantage of embedded systems is they don't do alot of writes to the CF Card (which you aren't running) and lower memory required (Which is also not an issue for you).  But yeah - Don't load every package you see…



  • How would i stay out of the webgui with no screen and such? Does the entire thing come over serial?
    (I'm fairly new to pfSense, only ever used embedded)



  • This thing doesn't have a VGA does it?

    No - Even with full install you are just looking at a bunch of text at install but with no VGA I've no idea if you can do it over serial with live CD.

    I have never tried.  Just seems a shame to have so much disk and ram handy and have to run embedded install.



  • Nope, just 1x USB, 4x NIC, 2x COM

    I'm guessing this image may work - pfSense-memstick-serial-2.1-RELEASE-i386.img.gz
    In the setup I could just dd it to the HDD instead of the USB stick I assume.

    But doesn't that load all kinds of hardware modules the Soekris doesn't have? Or is that a dynamic thing these days?
    Also, is the "full" version different where the update/2.1 install works better? Or has a higher chance of working?
    eg. would it be worth the trouble to try? Or is it just a wild experiment?



  • Wild experiment based purely on the fact that you seemed to have given up on 2.1 embedded.
    But with no SSD or CF Card to destroy with frequent writes, I'm not sure I'd want embedded unless I just couldn't do full install?



  • What would the benefit be, assuming it works?



  • Primarily, right of the bat…  First thing that jumps into my mind is squid.  Lots big huge cache.  Also RRD data storage.  You could use disk for cache instead of some big ram disk and memory for fast squid cache also.

    Assuming your CPU doesn’t cry...

    But I would not load too much on it.

    (Down-side is that a full install is more prone to corruption if you have a nasty habit of throwing the power switch without shut-down often)



  • Each Soekris will do; firewalling, load balancing (2x 40mbit dsl), DHCP, DNS, NTP and captive portal (Radius) and perhaps VPN on one of the machines.

    I could give it a go… I didn't fix the downed Soekris yet - Doing some other stuff now to lower the frustration levels :).
    Could I use the Memstick install (pfSense-memstick-serial-2.1-RELEASE-i386.img.gz)? Or what do you suggest?



  • I'm the wrong person to ask for the best embedded install type…  But I'd assume memstick will throw away most of your drive capacity, but work.



  • But I kinda need serial capability, if the regular download has that then that would work too I think ;)



  • https://doc.pfsense.org/index.php/Console_Types

    I'm not in love with the prospect of trying to do an install without a monitor!



  • Right, so for my hardware im limited to the nanobsd images or the memstick version.
    I'll is the memstick version more full featured than embedded that you know of?



  • Well - I think the nano versions are for particular sized CF cards so I'd think memstick is more flexible that way.



  • I see, i'll poke around a bit more and try to find out what's what.

    Thanks for your answers and advise.

    I've noticed there are a lot of people having trouble with 2.1, I hope it gets resolved soon :)
    I think I'm gonna dust off my old soekris (4801) to test out the differences between the various images.

    If I don't forget I'll post my findings in a thread somewhere on the forums here.


  • Netgate Administrator

    The memstick serial image is to write onto a usb stick. Then you boot from the USB stick, all the output is on the serial console, and install to the HD just like the CD. If you select the embedded kernel during the install you will then have a serial console by default when you then boot from the HD.

    Alternatively you can remove the HD and install pfSense to it in another machine from the CD. Once you have it installed and running you can enable a serial console in the webgui so that you have console access when you transfer it back to the soekris box.

    Steve



  • "Alternatively you can remove the HD and install pfSense to it in another machine from the CD. Once you have it installed and running you can enable a serial console in the webgui so that you have console access when you transfer it back to the soekris box."

    So you end up with a full install and a working console?  Correct?  I like this plan for a 250GB WD HDD.


  • Netgate Administrator

    Yes, exactly. I'm not sure quite what you get by selecting the embedded kernel, it used to be no packages but that isn't the case now, everything seems available - more than nano even. I have used this process for HD install on a firebox X-core-e but it's more difficult in that box. The process is described for an older box, and older pfSense, here:
    https://doc.pfsense.org/index.php/Soekris_4801_Hard_Drive_Installation

    Some stuff in that document no longer applies; you can choose the standard install and select serial console later, you don't need to do any VLAN stuff because you only need one interface to get up and running.

    When you tarnsfer back the HD and boot the box it will dump you at the assign interfaces dialogue because the NICs will (probably) be different in the Soekris box to the laptop.

    Steve



  • When I did this before (Transplanting a HDD) It worked right away because I went from having an EM0 and EM1 to a totally different box that still had an EM0 and EM1. Just dumb luck.



  • I've used the memstick serial to a USB stick of 4GB - Booted the Soekris, installed per default using the full 250GB disk in the Soekris (instead of nanoBSDs 4GB partition).
    Then selected "Embedded kernel" near the end and it seems to work so far. Trying to set up interfaces and stuff now. I just finished installing 5 minutes ago.

    So far so good…


  • Netgate Administrator

    Since you've not come back I hope it turned out OK. Sorry your upgrade experience wasn't the smooth transition everyone hopes for.  :)

    Steve



  • I've tried to upgrade my other soekris which also failed… Guess I need to re-install it with the memstick thing too, tomorrow...
    Which seems to work.

    When I dd in a copy of the NanoBSD variant the config keeps getting erased after a reboot. Somethings not right with the 4G image I think. But I can't really confirm.


  • Netgate Administrator

    Hmm, strange. Unless you really need the space, and I suggest you don't, then I would recommend you use the 2GB image on 4GB cards. The actual size of most 4GB cards is often less than 4GB, sometimes substantially. It's possible the config slice is corrupt because it not getting completely written to the card. If 2.0.3 worked though that shouldn't be an issue.  :-\

    Steve



  • Sounds like his settings were being saved in RAM not Disk.  Not sure how that would happen though.


  • Netgate Administrator

    It could not, or at least I've never seen or heard of it and can't think how it could!
    Completely missing config file, not just interface re-assign, is usually either corrupt storage somehow or mistakenly running live.

    Steve



  • Live would do it…



  • I just wanted to note that the embedded kernel is mainly intended for running on devices that can't run the regular kernel because of lack of VGA, etc.  It does not change anything about how pfSense writes to disk, where it writes to disk, or how often it writes to disk.  Some people have the mistaken notion that selecting the embedded kernel changes those aspects somehow, but it does not.  The partition layout and configuration of the internal scripts are what do that, which the kernel selection does not change.



  • Today I "fixed" the other soekris with the Memstick version which went without a hitch. yay!
    Both are now running pfSense 2.1.

    As mentioned earlier; Neither was upgradable from 2.0.3 using the 4G nanoBSD variant. Still not sure why.
    However, with the tips/ideas given here I think both systems now run faster than before. So it's not all bad. Just a day wasted on fixing stuff  :-\

    See attached image if you're curious where your help went :)




  • It looks considerably more neat than my table-o-network down in the basement  ;D

    Mine is old 65w dual core dell with a motley collection of Intel NICs, a 19inch CRT (with a tube) from before my kids were born and a keyboard from the 90s that just keeps going…  Looks like steampunk pfsense...

    Switches are all pretty new stuff - I couldn't find any 90s looking gigabit managed switches to match  :P


  • Banned

    HAHAHAHAHAHAHAHAHA!!



  • Cute installation there.



  • Supermule - I assume you are laughing with me…  not at me...  Hmmmmm???  ::)

    The other day my 17 year old boy asked me "Daddy - What is that big thing on the front of your car?"  I said "Thats called a bumper".

    Yeah...  I'm nostalgic you might say.



  • The cases + half of the interior came with the building i'm renting :) All the cabling into the office space was already in place too. Luckily… Saved us a ton of money.
    I just had to fill the gaps with switches and stuff to make it work!



  • So, now that all is right with your pfsense the moderators can rename this thread "Thanks for the utterly awesome 2.1 update."?



  • Well the update never worked. As mentioned above. Failed multiple times.
    But fresh installs did work.