• Hi,

    I noticed that in the system activity screen, WCPU goes to 100% ( Please see attached ). I saw similar posts on the forum but was not able to address the issue.

    In the Dashboard cpu usage is between 1% - 12% only.

    What gives?

    Activities done on the box are install packages squid and squidguard. Packages were then again uninstalled but looking at config.xml theres a section that says <squid>and <squidcache>and <squidnac>. Will it be safe to delete these blocks of code?

    ANY Suggestions please.

    Thank you.
    Configuration : Core 2 Duo, 1.8Ghz., 4 Gig. RAM, 160 Gig HD, 3 WAN Interfaces, 1 LAN
    ![Screen Shot 2013-09-17 at 10.46.49 AM.png](/public/imported_attachments/1/Screen Shot 2013-09-17 at 10.46.49 AM.png)
    ![Screen Shot 2013-09-17 at 10.46.49 AM.png_thumb](/public/imported_attachments/1/Screen Shot 2013-09-17 at 10.46.49 AM.png_thumb)</squidnac></squidcache></squid>

  • Packages leave their settings behind when uninstalled. That way, if you uninstall then install again, the previous settings stick/come back. Often that is what you want, but sometimes its annoying if you had a bad combination of settings and want to start again from scratch.
    Backup your config first, then if you are comfortable with making direct edits (deletes in this case) to config.xml and realise the risk if you stuff it up, then you can delete the various package sections.

    Those WCPU processes seem to be idle processes - are they just dummy things that count up the idle time on each CPU? Someone else can advise on that…

  • I always thought this was normal behavior. When all processes are at 0.00% or close to that then the CPU is 100% idle. Seems logical to me.

  • Netgate Administrator

    ^Excactly. What your are seeing is the system idle process, one for each core/CPU. When the core is doing nothing at all that uses the spare cycles. This is the expected behaviour.


  • Thanks! So there's nothing to worry about then.

  • Netgate Administrator

    Indeed, everything looks good.


Log in to reply