Gateway groups no options



  • Hi,

    since the update yesterday to version 2.1 I am not able anymore to configure the Gateway Priorities.

    At the summary the config is shown, but I cannot edit it.

    Maybe someone can help or confirm.

    Thanks :)



  • Is there some unusual history of your Gateway and Gateway Group names?
    It is all working fine for me - see attached screenshots.
    What does your Gateway Group summary screen look like?






  • It looks exactly the same as yours (but different descriptions) and it was for working unteil yesterdays for the last 3 months.



  • One guess is that there might be a problem with your gateway names, or gateway group names from 2.0.3 - maybe they have spaces before, after or in them, or some other odd thing that was not well validated in 2.0.3. And now in 2.1 those names are not being parsed properly. Or? Presumably something about your gateway and gateway group data format has a problem. Have a look at the gateways section of /cf/conf/config.xml - see what looks "odd".
    Here is my working one for reference:

    	 <gateways><gateway_item><interface>wan</interface>
    			<gateway>10.49.94.250</gateway>
    			<name>WANGW</name>
    			<weight>1</weight>
    			<ipprotocol>inet</ipprotocol>
    			<interval>2</interval>
    
    			<monitor>216.146.35.35</monitor>
    			 <defaultgw><latencylow>4000</latencylow>
    			<latencyhigh>5000</latencyhigh>
    			<losslow>40</losslow>
    			<losshigh>50</losshigh>
    			<down>30</down></defaultgw></gateway_item> 
    		 <gateway_item><interface>opt1</interface>
    			<gateway>10.49.95.250</gateway>
    			<name>OPT1GW</name>
    			<weight>1</weight>
    			<ipprotocol>inet</ipprotocol>
    			<interval>2</interval>
    
    			<monitor>216.146.36.36</monitor>
    			<latencylow>4000</latencylow>
    			<latencyhigh>5000</latencyhigh>
    			<losslow>40</losslow>
    			<losshigh>50</losshigh>
    			<down>30</down></gateway_item> 
    		 <gateway_group><name>WiMax_Priority</name>
    			WANGW|1|address
    			OPT1GW|2|address
    			<trigger>downloss</trigger></gateway_group> 
    		 <gateway_group><name>Balanced_Traffic</name>
    			WANGW|1|address
    			OPT1GW|1|address
    			<trigger>downloss</trigger></gateway_group> 
    		 <gateway_group><name>OpenVPNlisten</name>
    			OPT1GW|1|address
    			<trigger>down</trigger></gateway_group> 
    		 <gateway_group><name>OPT1_Priority</name>
    			WANGW|2|address
    			OPT1GW|1|address
    			<trigger>down</trigger></gateway_group></gateways> 
    


  • Thanks for your answer.
    Cannot find anything strange.

    Here is my config:

    	 <gateways><gateway_item><interface>wan</interface>
    			<gateway>194.33.xxx.xxx</gateway>
    			<name>gwTel</name>
    			<weight>1</weight>
    			 <interval><ipprotocol>inet</ipprotocol></interval></gateway_item> 
    		 <gateway_item><interface>opt4</interface>
    			<gateway>dynamic</gateway>
    			<name>gwCON</name>
    			<weight>1</weight>
    			 <interval><ipprotocol>inet</ipprotocol></interval></gateway_item> 
    		 <gateway_item><interface>lan</interface>
    			<gateway>192.168.250.1</gateway>
    			<name>gwDMZ</name>
    			<weight>1</weight>
    			 <interval><ipprotocol>inet</ipprotocol></interval></gateway_item> 
    		 <gateway_item><interface>opt3</interface>
    			<gateway>10.10.10.1</gateway>
    			<name>gw4G</name>
    			<weight>1</weight>
    			 <interval><ipprotocol>inet</ipprotocol></interval></gateway_item> 
    		 <gateway_group><name>gMail</name>
    			gwTel|1
    			gwCON|2
    			<trigger>down</trigger></gateway_group> 
    		 <gateway_group><name>gVPN</name>
    			gwCON|1
    			gw4G|2
    			<trigger>down</trigger></gateway_group> 
    		 <gateway_group><name>gBrowsing</name>
    			gwCON|2
    			gw4G|1
    			<trigger>down</trigger></gateway_group> 
    		 <gateway_group><name>gAllOutgoingWs</name>
    			gwTel|3
    			gwCON|2
    			gwDMZ|1
    			<trigger>down</trigger></gateway_group></gateways> 
    


  • <trigger>has 2 "gg" in mine, and in yours it is <triger>with only 1 "g". I imiagine that will have some effect, however that happened.</triger></trigger>



  • Oh… that was my mistake, because I was searching for gg in another script in another window and replaced it with g.

    Maybe the wrong tab was active.
    Sorry for that. It is fine in my file.

    I corrected the code above

    Maybe the ( ) are making problems in one of the descriptions :/



  • Any suggestions?
    Or can I just manually edit the config file to make changes?



  • I tried using () in descriptions, and that worked no problem. The code does check and only display gateways that match what it thinks is the relevant IP protocol. But all yours already have ipprotocol inet. I am guessing that it somehow thinks your gateway groups are for IPv6, and so does not list the IPv4 gateways, but I don't see how that happens in practice.
    Anyone else, feel free to give ideas…



  • Ok…
    I tried a lot of think, but its a productive environment, so I can't not change too much.
    So I have to wait for the next update, hoping this will fix it.

    But thank you very much for your help!!!



  • Could you check the page source and search for your gateway names? My guess is they're in there, but some javascript is acting up. Something like this happened to me with aliases and I had to add them in via the inspector in Chrome.



  • Hi,

    ok I was busy with checking the source code, when I noticed that one gateway disappeared from the summery.
    When I tried to re-add it, it says : You can not use a IPv4 Gateway Address on a IPv6 only interface.
    _So I went to the Gateway (which was disabled, but that is fine!) and enabled it to check the settings. It says: ipv6: none!

    Weird._ –> The Error came because it is an PPPoE device. But the message makes no sense ;) But it is fine now.

    Ok, it's working now, when the device/gateway is set to "enable".

    The Thing was disabled because it is not connected,yet. This was fine in pfsense 2.04.

    Anyway… I now know how to get the thing to work!

    THANK YOU VERY MUCH!


Log in to reply