Mirrored 2.0.1 ugrade/clean install to 2.1 fails



  • I am attempting to upgrade/clean install to 2.1 on a system running 2.0.1 using a mirrored disk config. If I try the AutoUpdate from the browser, it proceeds normally (I think) to the reboot but then puts a prompt about not finding a boot image and waits for some sort of input from me. Unfortunately, the keyboard is no longer active so I can't do anything but a hard reset of the box.

    When I try installing from the LiveCD, I can properly select the NICs and assign IP addresses but if/when I try to install to a hard drive using option 99, I get a pop-up stating that it couldn't find a suitable IDE or SCSI drive.

    I've successfully upgraded a single-disk system so I must be missing a step or something. I've read and searched but not been successful about finding any info.

    What am I doing wrong?

    Thanx,
    Garth



  • Not much response so I'm wondering if this has been tried by anyone. If not, is a mirrored install still supported in 2.1? I guess what I'll try next is to remove all traces of the mirror including zeroing the superblock and try a clean install. That failing, I'll unplug one of the drives and try again.

    Any helpful suggestions welcome.

    Thanx,
    Garth



  • Well I tried rebuilding with 2.0.1 but without the mirror and all seemed to go well so then I tried installing clean with 2.1 with the same result: No IDE or SCSI drives detected. I'm using an old Dell SC430 server with a Pentium D (original multi-core CPU) and 4G RAM and it works fine with 2.0.1 but not (so far) with 2.1. The box has worked well with everything but 2.1 including ESXi, various Linux distros, pfSense 2.0.1 and previous, and various Windows versions.

    Any suggestions?

    Thanx,
    Garth


  • Netgate Administrator

    Did you ever try any of the 2.1 beta/RC images?

    2.1 is built on FreeBSD 8.3 which has better hardware support. This is mostly good but it can cause a problem if some bit of hardware on your board that was previously sitting doing nothing suddenly springs to life.  ;)
    I suspect your HD controller may be operating with a different/modified driver. Often under 2.0.X you would have to select a legacy controller mode in order for pfSense to use it. If you have done that try changing it back to AHCI mode for example. Try changing the disk controller mode anyway even if it's a still at the default.

    Steve



  • As to the Beta, I never knew it was in progress until the dashboard indicated that an update was available. As to BIOS, I never changed any settings but I'll take a look to ensure that all is normal.

    So the latest pfSense is on v8.3 of FreeBSD? I was about to give 9.1 a try just to see what happened but that may not be productive.

    Thanx,
    Garth


  • Netgate Administrator

    Yes, it's 8.3. Trying to load FreeBSD 8.3 would be informative.

    Seeing no drives or drive controllers can usually be rectified by trying a different mode though.

    Steve



  • @garthk:

    Not much response so I'm wondering if this has been tried by anyone. If not, is a mirrored install still supported in 2.1?

    I can confirm that mirroring still works in 2.1, at least with the hardware I'm using. I upgraded from 2.0.3, and it went smoothly. gmirror status reports that my RAID is "COMPLETE" and all 3 drives are "ACTIVE".



  • garthk,

    can you boot your clean 2.0.1 install, go to Diagnostics, Command Prompt, and in the top box type dmesg and execute, then paste the results here?
    (and since I no longer have 2.0.1 boxes, and can't remember if that menu is there or not, you may just need to go to http://ip.of.your.pfsense/exec.php)

    It may help to determine what is going on.

    My gmirror setup survived the upgrade no problem, I doubt its the mirror that is the problem, but a driver problem.



  • Sure can and I appreciate the responses. Note that this install is not mirrored since I was trying to test with a single drive to see if that made a difference (it didn't). If I need to rebuild using a mirror, let me know and I can do that. BTW, the install for 2.1 did not give me the option to set up a mirror during install. No big surprise, I guess, since it didn't see any drives.

    Thanx again,
    Garth

    pfsense.localdomain

    System
        Interfaces
        Firewall
        Services
        VPN
        Status
        Diagnostics
        Help

    Diagnostics: Execute command

    $ dmesg
    Copyright © 1992-2010 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 8.1-RELEASE-p6 #0: Mon Dec 12 17:53:00 EST 2011
        root@FreeBSD_8.0_pfSense_2.0-snaps.pfsense.org:/usr/obj./usr/pfSensesrc/src/sys/pfSense_SMP.8 i386
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Intel(R) Pentium(R) D CPU 2.80GHz (2793.02-MHz 686-class CPU)
      Origin = "GenuineIntel"  Id = 0xf44  Family = f  Model = 4  Stepping = 4
      Features=0xbfebfbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>Features2=0x641d <sse3,dtes64,mon,ds_cpl,cnxt-id,cx16,xtpr>AMD Features=0x20100000 <nx,lm>TSC: P-state invariant
    real memory  = 4294967296 (4096 MB)
    avail memory = 3926814720 (3744 MB)
    ACPI APIC Table: <dell  pesc430="">FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
    FreeBSD/SMP: 1 package(s) x 2 core(s)
    cpu0 (BSP): APIC ID:  0
    cpu1 (AP): APIC ID:  1
    ioapic0: Changing APIC ID to 8
    ioapic0 <version 2.0="">irqs 0-23 on motherboard
    lapic0: Forcing LINT1 to edge trigger
    netisr_init: forcing maxthreads to 1 and bindthreads to 0 for device polling
    wpi: You need to read the LICENSE file in /usr/share/doc/legal/intel_wpi/.
    wpi: If you agree with the license, set legal.intel_wpi.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (wpi_fw, 0xc0988300, 0) error 1
    ipw_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_bss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_bss_fw, 0xc0789340, 0) error 1
    ipw_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_ibss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_ibss_fw, 0xc07893e0, 0) error 1
    ipw_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_monitor: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_monitor_fw, 0xc0789480, 0) error 1
    wlan: mac acl policy registered
    kbd1 at kbdmux0
    cryptosoft0: <software crypto="">on motherboard
    padlock0: No ACE support.
    acpi0: <dell pesc430="">on motherboard
    acpi0: [ITHREAD]
    acpi0: Power Button (fixed)
    acpi0: reservation of 0, a0000 (3) failed
    acpi0: reservation of 100000, f00000 (3) failed
    acpi0: reservation of 1000000, eee8cc00 (3) failed
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
    cpu0: <acpi cpu="">on acpi0
    cpu1: <acpi cpu="">on acpi0
    acpi_hpet0: <high precision="" event="" timer="">iomem 0xfed00000-0xfed003ff on acpi0
    Timecounter "HPET" frequency 14318180 Hz quality 900
    acpi_button0: <power button="">on acpi0
    acpi_button0: enable wake failed
    pcib0: <acpi host-pci="" bridge="">port 0xcf8-0xcff on acpi0
    pci0: <acpi pci="" bus="">on pcib0
    pcib1: <acpi pci-pci="" bridge="">irq 16 at device 1.0 on pci0
    pci1: <acpi pci="" bus="">on pcib1
    igb0: <intel(r) 1000="" pro="" network="" connection="" version="" -="" 2.2.3="">port 0xdcc0-0xdcdf mem 0xfeac0000-0xfeadffff,0xfe000000-0xfe3fffff,0xfeab8000-0xfeabbfff irq 16 at device 0.0 on pci1
    igb0: Using MSIX interrupts with 3 vectors
    igb0: [ITHREAD]
    igb0: [ITHREAD]
    igb0: [ITHREAD]
    igb1: <intel(r) 1000="" pro="" network="" connection="" version="" -="" 2.2.3="">port 0xdce0-0xdcff mem 0xfeae0000-0xfeafffff,0xfe400000-0xfe7fffff,0xfeabc000-0xfeabffff irq 17 at device 0.1 on pci1
    igb1: Using MSIX interrupts with 3 vectors
    igb1: [ITHREAD]
    igb1: [ITHREAD]
    igb1: [ITHREAD]
    pcib2: <acpi pci-pci="" bridge="">irq 16 at device 28.0 on pci0
    pci2: <acpi pci="" bus="">on pcib2
    pcib3: <acpi pci-pci="" bridge="">irq 16 at device 28.4 on pci0
    pci3: <acpi pci="" bus="">on pcib3
    pcib4: <acpi pci-pci="" bridge="">irq 17 at device 28.5 on pci0
    pci4: <acpi pci="" bus="">on pcib4
    bge0: <broadcom netxtreme="" gigabit="" ethernet="" controller,="" asic="" rev.="" 0x004001="">mem 0xfdef0000-0xfdefffff irq 17 at device 0.0 on pci4
    miibus0: <mii bus="">on bge0
    brgphy0: <bcm5750 10="" 100="" 1000basetx="" phy="">PHY 1 on miibus0
    brgphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
    bge0: [ITHREAD]
    uhci0: <intel 82801g="" (ich7)="" usb="" controller="" usb-a="">port 0xff80-0xff9f irq 21 at device 29.0 on pci0
    uhci0: [ITHREAD]
    uhci0: LegSup = 0x3000
    usbus0: <intel 82801g="" (ich7)="" usb="" controller="" usb-a="">on uhci0
    uhci1: <intel 82801g="" (ich7)="" usb="" controller="" usb-b="">port 0xff60-0xff7f irq 22 at device 29.1 on pci0
    uhci1: [ITHREAD]
    usbus1: <intel 82801g="" (ich7)="" usb="" controller="" usb-b="">on uhci1
    uhci2: <intel 82801g="" (ich7)="" usb="" controller="" usb-c="">port 0xff40-0xff5f irq 18 at device 29.2 on pci0
    uhci2: [ITHREAD]
    usbus2: <intel 82801g="" (ich7)="" usb="" controller="" usb-c="">on uhci2
    uhci3: <intel 82801g="" (ich7)="" usb="" controller="" usb-d="">port 0xff20-0xff3f irq 23 at device 29.3 on pci0
    uhci3: [ITHREAD]
    usbus3: <intel 82801g="" (ich7)="" usb="" controller="" usb-d="">on uhci3
    ehci0: <intel 82801gb="" r="" (ich7)="" usb="" 2.0="" controller="">mem 0xffa80800-0xffa80bff irq 21 at device 29.7 on pci0
    ehci0: [ITHREAD]
    usbus4: EHCI version 1.0
    usbus4: <intel 82801gb="" r="" (ich7)="" usb="" 2.0="" controller="">on ehci0
    pcib5: <acpi pci-pci="" bridge="">at device 30.0 on pci0
    pci5: <acpi pci="" bus="">on pcib5
    vgapci0: <vga-compatible display="">port 0xcc80-0xccff mem 0xfa000000-0xfbffffff,0xfdcc0000-0xfdcfffff at device 7.0 on pci5
    isab0: <pci-isa bridge="">at device 31.0 on pci0
    isa0: <isa bus="">on isab0
    atapci0: <intel ich7="" udma100="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xffa0-0xffaf irq 16 at device 31.1 on pci0
    ata0: <ata 0="" channel="">on atapci0
    ata0: [ITHREAD]
    atapci1: <intel ich7="" sata300="" controller="">port 0xfe00-0xfe07,0xfe10-0xfe13,0xfe20-0xfe27,0xfe30-0xfe33,0xfea0-0xfeaf irq 20 at device 31.2 on pci0
    atapci1: [ITHREAD]
    ata2: <ata 0="" channel="">on atapci1
    ata2: [ITHREAD]
    ata3: <ata 1="" channel="">on atapci1
    ata3: [ITHREAD]
    pci0: <serial bus,="" smbus="">at device 31.3 (no driver attached)
    atrtc0: <at realtime="" clock="">port 0x70-0x7f irq 8 on acpi0
    uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    uart0: [FILTER]
    pmtimer0 on isa0
    orm0: <isa option="" roms="">at iomem 0xc0000-0xc7fff,0xc8000-0xc9fff,0xca000-0xcbfff pnpid ORM0000 on isa0
    sc0: <system console="">at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    vga0: <generic isa="" vga="">at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    atkbdc0: <keyboard controller="" (i8042)="">at port 0x60,0x64 on isa0
    atkbd0: <at keyboard="">irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    atkbd0: [ITHREAD]
    ppc0: parallel port not found.
    p4tcc0: <cpu frequency="" thermal="" control="">on cpu0
    p4tcc1: <cpu frequency="" thermal="" control="">on cpu1
    Timecounters tick every 1.000 msec
    IPsec: Initialized Security Association Processing.
    usbus0: 12Mbps Full Speed USB v1.0
    usbus1: 12Mbps Full Speed USB v1.0
    usbus2: 12Mbps Full Speed USB v1.0
    usbus3: 12Mbps Full Speed USB v1.0
    usbus4: 480Mbps High Speed USB v2.0
    acd0: CDROM <gcr-8485b 1.06="">at ata0-master UDMA33
    ugen0.1: <intel>at usbus0
    uhub0: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usbus0
    ugen1.1: <intel>at usbus1
    uhub1: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usbus1
    ugen2.1: <intel>at usbus2
    uhub2: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usbus2
    ugen3.1: <intel>at usbus3
    uhub3: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usbus3
    ugen4.1: <intel>at usbus4
    uhub4: <intel 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr="">on usbus4
    ad4: 76293MB <wdc wd800jd-75msa2="" 10.01e03="">at ata2-master UDMA100 SATA
    ad5: 76293MB <wdc wd800jd-75msa2="" 10.01e03="">at ata2-slave UDMA100 SATA
    lapic1: Forcing LINT1 to edge trigger
    SMP: AP CPU #1 Launched!
    GEOM: ad5s1: geometry does not match label (255h,63s != 16h,63s).
    Root mount waiting for: usbus4 usbus3 usbus2 usbus1 usbus0
    uhub0: 2 ports with 2 removable, self powered
    uhub1: 2 ports with 2 removable, self powered
    uhub2: 2 ports with 2 removable, self powered
    uhub3: 2 ports with 2 removable, self powered
    Root mount waiting for: usbus4
    Root mount waiting for: usbus4
    Root mount waiting for: usbus4
    uhub4: 8 ports with 8 removable, self powered
    Trying to mount root from ufs:/dev/ad4s1a
    ugen1.2: <microsoft>at usbus1
    ums0: <microsoft 0="" 2="" microsoft="" optical="" mouse="" with="" tilt="" wheel,="" class="" 0,="" rev="" 2.00="" 1.20,="" addr="">on usbus1
    ums0: 3 buttons and [XYZT] coordinates ID=17
    ums0: 0 buttons and [T] coordinates ID=0
    ugen2.2: <dell>at usbus2
    ukbd0: <dell 0="" 2="" dell="" usb="" entry="" keyboard,="" class="" 0,="" rev="" 1.10="" 1.15,="" addr="">on usbus2
    kbd2 at ukbd0
    pflog0: promiscuous mode enabled
    bge0: link state changed to UP
    igb0: link state changed to UP</dell></dell></microsoft></microsoft></wdc></wdc></intel></intel></intel></intel></intel></intel></intel></intel></intel></intel></gcr-8485b></cpu></cpu></at></keyboard></generic></system></isa></at></serial></ata></ata></intel></ata></intel></isa></pci-isa></vga-compatible></acpi></acpi></intel></intel></intel></intel></intel></intel></intel></intel></intel></intel></bcm5750></mii></broadcom></acpi></acpi></acpi></acpi></acpi></acpi></intel(r)></intel(r)></acpi></acpi></acpi></acpi></power></high></acpi></acpi></dell></software></version></dell ></nx,lm></sse3,dtes64,mon,ds_cpl,cnxt-id,cx16,xtpr></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>


  • Netgate Administrator

    So to confirm, you have two 80GB SATA drives and they're both on the same channel?

    Since you are using SATA drives this suggests even more strongly (to me) that changing the SATA mode in the bios could be the solution. Unless you've already tried that.  ;)

    Steve



  • Correct but I have not tried changing the bios settings yet. To be clear, I will change a setting in the bios back to AHCI if not already set to that and retest, attempting a clean 2.1install.

    Thanx,
    Garth


  • Netgate Administrator

    That's exactly what I would do.  :)
    AHCI is now the recommended setting for SATA drives.

    Steve



  • The controller is listed as SATA-2 but there is no option anywhere in the bios settings that references AHCI. This box may just be too old?

    Thanx,
    Garth


  • Netgate Administrator

    Hmm, yes P4 would have been at the very beginning of the SATA era. Some of those early SATA controllers can give all sorts of problems, especially those that used separate on-board chips from some other company. I have a box here that will not boot Linux from it's SATA drive no matter what I do to it. Your SATA controller seems to be part of the ICH7 chipset so I would expect better support. Are you on the latest BIOS? Separate SATA firmware?

    Steve



  • It appears that the Dell SC430 BIOS does not have the option of setting AHCI as discussed in this link: http://rants.atmurray.net/2009/06/sata-ahci-mode-on-systems-without-bios.html.

    There is a Linux hack to modify the grub loader but I would have no idea how to do that in FreeBSD.

    Probably time to virtualize pfSense or find another box to run it on.

    Note: I just saw you latest post and, while I normally keep the BIOS up-to-date, I'll check to see if there is a newer one.

    Thanx,
    Garth



  • Well, I moved to a newer box and I can state that 2.1 installs successfully using a mirrored config.

    Thanx for all the help,
    Garth


Log in to reply