[solved] RRD Quality Graph not working after 2.1 upgrade



  • The subject says it all - the quality graphs just go blank after the time when the upgrade was completed.  I am on x64 and had a very easy/successful upgrade.  This is the only issue I have seen so far.



  • Did you go ahead and delete RRD data?



  • I have not yet as I would prefer to keep the data for continuity sake.  Is there a way to only delete the 'quality' data but retain the other items like traffic etc.?



  • No idea.  When mine quit (because I was screwing with packages) I just deleted it and started over.
    For me, RRD data isn't all that important.  I will go in and check my logs to see if there is VPN traffic when there shouldn't be so that I can quick remediate a hack if it happens, but other than that sort of spot checking the health, I'm in no need of long logs.



  • Apparently the upgrade renamed my gateway from WAN to WAN_DHCP.  The quality has been logging properly and the graphs look fine once I select the 'new' gateway.



  • I wonder if there is some method to combine WAN and WAN_DHCP, I've got 4 years of data on WAN, I really enjoy being able to see the trends!



  • Rename the gateway back to WAN, you'll only be missing the data from when you upgraded to 2.1 to when you rename the gateway.



  • Thanks:

    The following input errors were detected:
    
    Changing name on a gateway is not allowed.
    


  • Delete the gateway, then re-add it using the old name.



  • Super, worked great, thanks!



  • @mhab12:

    Delete the gateway, then re-add it using the old name.

    I still have no Quality data.  Where did you mean to delete and re-add the gateway?  Under Interfaces > (assign)?



  • I just upgraded a pfSense 2.0 install to pfSense 2.2.x and I'm seeing the same issue. My real gateway is not listed under RRD Quality instead I see an entry called WAN_DHCP without any stats at all. I've never used DCHP for the WAN connection on this setup so this puzzles me a bit.

    I'll report back if I manage to figure out a workaround or fix.

    Edit: Turns out my gateway had the "Disable Gateway Monitoring" option checked, when I removed it the real gateway showed up in the list above the RRD graph.


Log in to reply