[SOLVED] VIP - Alias working, but there is no DHCP?



  • Hello everyone, I just recently disabled 2 NICs (a RealTek RTL8139 and an Intel Pro/100+) so that I can just have multiple subnets on one network card (LAN), and I read about using Virtual IPs to make this possible, and I added 3 network addresses as follows:

    
    172.16.0.9/29 - Xbox LAN
    172.32.0.1/30 - Server LAN*
    172.16.0.4/32 - Primary LAN as a loopback
    
    

    *Going to change it to a 172.16.0.x/30 network instead

    And surprisingly I can ping and access via webconfig all 3 addresses from either my wireless router (static routing to my pfSense box) or the primary LAN.  However, I need to use DHCP for my Xbox 360 since using static causes an NAT type strict and online gaming has lagging issues and downloads don't finish.

    Are there commands that I can use to make the other networks listed above (excluding the 172.16.0.4/32 address) as aliases?

    I did, in fact, input the following line of code in the config file listed below:

    
    <shellcmd>ifconfig rl0 inet 172.16.0.9 netmask 255.255.255.248 alias</shellcmd>
    <shellcmd>ifconfig rl0 inet 172.32.0.1 netmask 255.255.255.252 alias</shellcmd>
    
    

    I also added the rule sets for the networks listed above to allow access to the Internet both in Firewall -> Rules and Firewall -> NAT -> Outbound to allow access to the Internet and to access ports 1024-65535

    I wish I can use VLANs for the networking, but I need to purchase a $200-$500 smart or managed switch that supports VLAN configuration.


  • Banned

    So you basically broke a working sensible setup to replace it with this horrible kludge? Uh. Either undo the harm you did, or stick everything on one subnet. And on that note, 172.32.0.1/30 is NOT a private RFC1918 space! The "class B" reserved space is  172.16.0.0 - 172.31.255.255 (i.e., 172.16/12). That IP you are using is assigned to T-Mobile USA.



  • @doktornotor:

    So you basically broke a working sensible setup to replace it with this horrible kludge? Uh. Either undo the harm you did, or stick everything on one subnet.

    I undid the harm by removing the Virtual IPs, and I did set the IP addresses for each interface since the Virtual IP routine didn't have enough options.

    So this pretty much solved the problem.

    Thanks.


Log in to reply