Help with a DNS option



  • 
    C:\>nslookup time.nist.gov
    Server:  pfsense.removed.ath.cx
    Address:  192.168.21.1
    
    Non-authoritative answer:
    Name:    removed.ath.cx
    Address:  X.X.X.X                    <==  (This is whatever my WAN IP is, which is the wrong IP)
    Aliases:  time.nist.gov.removed.ath.cx
    
    C:\>nslookup time.nist.gov.                    <== notice the period at the end of the FQDN this time
    Server:  pfsense.removed.ath.cx
    Address:  192.168.21.1
    
    Non-authoritative answer:
    Name:    time.nist.gov
    Address:  192.43.244.18                    <== (This is the right IP)
    
    

    Anyone know what option I need to set to keep the pfsense dns forwarder from auto appending my domain to the end of anything I ping or do a lookup onto?  It is getting quite annoying.  Most other DNS's I use (Windows, BIND) don't require me to put a period at the end whenever I put in the FQDN.



  • If I remember correctly the RFC for DNS does have the requirement to place a period at the end of the FQDN (absolute name) otherwise the DNS server IS supposed to put the local domain information at the end of the domain name listed as it "thinks" you have only listed the host name WITHOUT the domain part (relative name).

    This link explains what is supposed to be…

    http://www.ietf.org/rfc/rfc1034.txt

    As for Microsoft not requiring it - well - let's just say it is not the ONLY thing Microsoft does NOT do in respect to the RFC requirement!

    RFC: Request For Comments - These documents comprise how inter-networking is supposed to work!

    RFC's are you friend!

    gm...



  • So there is not option to have pfsense' DNS server/forwarder assume I'm putting in an FQDN if I have at least 1 period somwhere in the query but not necessarily at the end (like google.com)?


Log in to reply