Alix wifi won't re-start with upgrade to 2.1



  • Hi did an upgrade to 2.1 all worked well for a week

    changed wifi from wep to wpa and now I get this error and wifi won't start, going back to old settings gives the same error

    Sep 20 18:36:45 php: /interfaces.php: The command '/sbin/ifconfig 'ath0_wlan0' inet delete' returned exit code '1', the output was 'ifconfig: ioctl (SIOCDIFADDR): Can't assign requested address



  • Tried some more stuff but still can't get the wifi up

    $ ifconfig ath0_wlan0
    ath0_wlan0:
    flags=8c02 <broadcast,oactive,simplex,multicast>metric 0
    mtu 1500
    ether a8:54:b2:9f:44:2a
    inet6 fe80::aa54:b2ff:fe9f:442a%ath0_wlan0 prefixlen 64 scopeid 0x9 
    inet 192.168.24.1 netmask 0xffffff00 broadcast 192.168.24.255
    nd6 options=1 <performnud>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <turbo>(autoselect)
    status: no carrier
    ssid "24 Lubrano dual link" channel 11 (2462 MHz 11g)
    country US ecm authmode WPA1+WPA2/802.11i
    privacy OFF
    txpower 22
    bmiss 7
    scanvalid 60 bgscan bgscanintvl 300 bgscanidle 250 roam:rssi 7

    In the above there is an inet6 address?? that strange I am not trying to config Ip6

    if I run $ ifconfig ath0_wlan0 inet delete it delets the ip4 address ok

    if I run again I get
    ifconfig: ioctl (SIOCDIFADDR): Can't assign requested address

    if I run $ ifconfig ath0_wlan0 inet6 delete I get
    ifconfig: ioctl (SIOCDIFADDR): Can't assign requested address

    I think think has something to do with the new ip6 features added in the latest version</turbo></performnud></broadcast,oactive,simplex,multicast>


  • Netgate Administrator

    Is this interface bridged to LAN by any chance?

    Steve



  • Hi, no the is no bridge step-up, see the screen shot

    ![Screen Shot 2013-09-27 at 12.32.07 PM.png](/public/imported_attachments/1/Screen Shot 2013-09-27 at 12.32.07 PM.png)
    ![Screen Shot 2013-09-27 at 12.32.07 PM.png_thumb](/public/imported_attachments/1/Screen Shot 2013-09-27 at 12.32.07 PM.png_thumb)


  • Netgate Administrator

    Hmm, anything else in the logs? Are you specifying a connection speed at all?
    https://forum.pfsense.org/index.php?topic=66653.0

    Steve



  • Thanks Steven. I did the same selection as the thread link you posted and the interface came up !!

    Its now working but I did get these in the logs

    Sep 30 17:11:31 php: /interfaces.php: The command '/sbin/ifconfig 'ath0_wlan0' inet delete' returned exit code '1', the output was 'ifconfig: ioctl (SIOCDIFADDR): Can't assign requested address'
    Sep 30 17:11:32 php: /interfaces.php: The command '/sbin/ifconfig 'ath0_wlan0' media 'autoselect' mediaopt 'mode'' returned exit code '1', the output was 'ifconfig: SIOCSIFMEDIA (media): Device not configured'

    The first error message seems to occur if there was not an IP already assigned to the interface, maybe its not a problem. I never see this on WAN or LAN interfaces.

    No idea why an invalid autoselect setting would then cause the interface to work

    The other thread said that problem came back, I not looking forward to that, my alix board is new, I would have though the combo of pfsense 2.1 and alix was very common, hoping for a more solid fix in the future, happy to do any testing requested - this router id defiantly not ready for production work.

    Maybe I should go back to the previous release, any suggestions welcome.



  • I have an ath0 WiFi running inside an Alix2D13 on 2.1-RELEASE at a remote site. It ran various 2.1-RCn and was updated remotely a few times and it has been working. The settings (with SSID and password changed) are in the attached. At that site the power goes off a lot, and it comes back [both power and WiFi :) ] Maybe that will give you some confidence?









Log in to reply