PfSense and Layer 3 Switch Doing Inter VLAN Routing



  • I have pfSense 2.1 in front of a Cisco 3550 layer 3 switch. The layer 3 switch is currently doing the inter vlan routing. The pfSense LAN interface is 10.0.0.1/30 and the switch interface is 10.0.0.2/30. I am able to ping the pfSense LAN interface from the switch but when I plug a workstation into FastEthernet0/48 it is unable to pull an ip address from the DHCP server on pfsense. I have not created any vlans on pfSense, just a WAN and LAN interface. Not sure if I need to add static routes on the pfsense box. Any help would be greatly appreciated. Thanks!

    On the switch:

    interface FastEthernet0/1
    no switchport
    ip address 10.0.0.2 255.255.255.252

    interface FastEthernet0/48
    switchport access vlan 100
    switchport mode access
    spanning-tree portfast

    VLAN 100
    ip address 10.0.100.1 255.255.254.0
    ip helper-address 10.0.0.1

    VLAN 105
    ip adress 10.0.105.1 255.255.255.0
    ip helper-address 10.0.0.1

    router ospf 1
    network 10.0.100.0 255.255.254.0 area 0
    network 10.0.105.0 255.255.255.0 area 0

    ip route 0.0.0.0 0.0.0.0 10.0.0.1



  • Hmmm. I think pfSense cannot be the DHCP for this particular setup. For the LAN interface, DHCP server is set to serve only the 10.0.0.0/30 network. No other possible way to have pfSense hand out ip addresses from the 10.0.100.0/23 range unless I create VLAN 100 on pfsense but that messes everything up.



  • I'm doing a fix fot that. Take a look on bounty topic.


Log in to reply