Problem Installing v2.0.3 on Alix 2D13



  • I've had a Alix 2D13 based pfSense 1.2.3 firewall up and running reliably for 4+ years. This hardware / software combination has been extremely reliable. Recently I tried installing pfSense v2.0.3 on the exact same backup system but I having problems having the Alix board recognize the new image. My process is as follows:

    1> Downloaded the pfSense embedded image (tried multiple time to be sure it wasn't the download)
    2> then used to following command from my MacBook Pro to install the image on a 2G CF card:

    sudo gzcat pfSense-2.0.3-RELEASE-2g-i386-nanobsd-20130412-1022.img.gz | dd of=/dev/disk1 bs=16k

    3>After the successful completion of this command I install the CF card into the Alix board and connect using my USB to Serial Plugable.com connector
    4>On my serial console I watch the Alix booard boot up but then I receive a stream of garbage text: Here's a screen copy of what I'm seeing:

    PC Engines ALIX.2 v0.99
    640 KB Base Memory
    261120 KB Extended Memory

    01F0 Master 045A Emphase CF4000XI2G
    Phys C/H/S 4063/16/63 Log C/H/S 1015/64/63
    x €xx€ € € x€x€xx€xøx€xxxø €x€€€ € € x€x€xx€xøx€xxxø €x€x€ xø€ € x xx xø €x€ xøxøxøxø€ € €x€ €ø €ø €ø €ø €

    You'll note that I'm running the 0.99 version of the Alix firmware. You see the memory test but when it accesses the CF card I receive garbage. This is the exact same procedure and hardware I used 4+years ago to create my existing pfSense v1.2.3 firewall.

    Any assistance offered would be greatly appreciated.


  • Netgate Administrator

    Firstly I would go straight to 2.1 since the upgrade procedure on very low memory systems seems to be giving trouble for some.

    What size CF card are you using? If it's 2GB then the first thing I would try is using the 1GB image.

    Are you using the correct console speed? During pfSense boot it should be 9600bps, I'm not sure what it is for the Alix bios.

    Steve



  • The BIOS should be:

    PC Engines ALIX.2 v0.99h
    

    Somehow the "h" rev is not there.
    Might be the problem, but in any case it should be updated to 0.99h
    https://doc.pfsense.org/index.php/ALIX_BIOS_Update_Procedure



  • I concur with the previous posters.
    Update the BIOS to 99h and then go right to 2.1
    2.1 seems to be more responsive and doesn't hang on the ntp when you boot the unit offline.
    The Alix defaults to 38400, so if you haven't changed it to 9600, you should press S during the mem test, then 9, then Q.



  • Thanks for your help….upgraded the firmware to .99H from .99 and that did the trick! Once past that I have a baud rate mismatch I needed to correct...the ALix board was set to 38400 while pfSense was set to 9600...Thanks again to all who responded


Log in to reply