Errors after upgrade to 2.1



  • Hello,
    I just update from 2.0.3 to 2.1-RELEASE (i386).
    To do that, i use the link "update" on the dashboard.

    After reboot, i have an error "Fatal error: Call to undefined function curl_init() in /etc/inc/pfsense-utils.inc on line 1627 " on the dashboard and when i tried to download packages or modify some services

    I google it, an i find that in some case we must apply the firmware upgrade vith the "tgz" file.

    I tried it, but now i have 2 errors:
    "Fatal error: Call to undefined function curl_init() in /etc/inc/pfsense-utils.inc on line 1627 "
    and a picture with the message " Packages are currently being reinstalled in the background. Do not make changes in the GUI until this is complete."

    What can i do?

    Thanks in advance ;)


  • Rebel Alliance Developer Netgate

    Make sure you completely clean your browser cache out, or try a different browser. Your browser may have cached something from before the upgrade.



  • Hello!!
    Thanks for your answer.

    After cleaning cache and/or changing browser, the issue is the same >:(.

    Any other idea(s)?? :'(



  • Hi all!!
    So, i resolve one issue of 2:
    For the "Packages are currently being reinstalled in the background. Do not make changes in the GUI until this is complete.", i go to Diagnostics> Backup/restore then i click on the button "clear lock for package instalaltion" and the picture & message disappear  ;D

    But, i have always the error "Fatal error: Call to undefined function curl_init() in /etc/inc/pfsense-utils.inc on line 1627 " on the Dashboard (after "obtainig update status") :'(

    Anybody have the same situation or a solution?

    Have a good weekend!



  • Clear your system log.



  • Same error after applying from the full upgrade package even with clear log.



  • please up.


Log in to reply