[RESOLVIDO] Erro Squid3-DEV 3.3.8 pkg 2.1.2



  • Bom dia senhores,

    Estou com problemas no pacote Squid3-DEV no PFSense 2.1. Sei que é o Marcelloc que está desenvolvendo esse pacote e também sei que é experimental.

    Estou usando a ultima versão do pacote publicada no diretório do oficial.

    Quando tento ativar o Squid, recebo este erro no LOG e o serviço não sobe:

    
    Sep 24 10:56:17 	php: /pkg_edit.php: The command '/usr/pbi/squid-amd64/sbin/squid -z -f /usr/pbi/squid-amd64/etc/squid/squid.conf' returned exit code '1', the output was '/libexec/ld-elf.so.1: Shared object "libheimntlm.so.10" not found, required by "squid"'
    
    


  • Já baixou as bibliotecas dependentes e habilitou o ipv6?

    fetch -o /usr/local/lib/libasn1.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libasn1.so.10
    fetch -o /usr/local/lib/libgssapi.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libgssapi.so.10
    fetch -o /usr/local/lib/libheimntlm.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libheimntlm.so.10
    fetch -o /usr/local/lib/libhx509.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libhx509.so.10
    fetch -o /usr/local/lib/libkrb5.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libkrb5.so.10
    fetch -o /usr/local/lib/libroken.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libroken.so.10
    


  • Olá!

    Obrigado pela resposta, vou fazer o Download.

    Pensei que todas as dependências eram baixadas junto com o pacote.



  • @LFCavalcanti:

    Olá!

    Obrigado pela resposta, vou fazer o Download.

    Pensei que todas as dependências eram baixadas junto com o pacote.

    Estas bibliotecas que trabalham junto com o sasl fazem parte da base do sistema operacional e até hoje não consegui convencer o core team a inclui-las na instalação padrão. :(

    Outros pacotes como o freeradius e o postfix também precisam delas.

    Tenho duas opções:

    • Remover a autenticação sasl do squid3

    • Continuar fazendo o download na mão



  • Entendi.

    Seria interessante especificar isso no manifesto do pacote e também gerar aviso durante a instalação, já te poupa o tempo de ficar respondendo tópicos como esse meu.  ;D

    EDIT: Problema resolvido, só baixar as dependências citadas.


Log in to reply