Unable to install OpenVPN



  • I am unable to reinstall OpenVPN (both 2.2 and 2.3-x86) for Windows 7 64-bit.  I previously had it on my computer and because of issues with the software attempted to remove it.  I do not see the software anywhere on the PC, but when I go to reinstall it, the install wizard comes up with the "Install" option and when I click it, it quickly goes away and then the typical error message for Windows 7 appears that says the program may not have installed correctly and to reinstall it.  I know when I've previously installed this, it goes through a couple screens for quite a few seconds/minutes, but it doesn't even get that far anymore.

    I've tried everything possible and I'm out of ideas.  I'm a domain admin, I'm using my domain admin account, ran as admin, everything.  Nothing seems to work.  I just want to completely remove OpenVPN and start from scratch, but I have a feeling that there are some files hiding out there in the registry that I can delete, but when I search online I see tons of different registry instances to delete but I can never find anything in the locations specified.

    Help please!!



  • Not sure about 64-bit in particular. But I have had to do some cleanup in the past to get rid of old OpenVPN installation bits:

    1. Program Files\OpenVPN - there might be a config folder, and\or OpenVPNManager\config folder. Work hard to delete the whole Program Files\OpenVPN tree.
    2. Look in the services list for OpenVPN, you might need to get rid of it:
    sc delete openvpn
    

    Then you will be able to complete step 1.
    Edit: added the space between "sc" and "delete"



  • Thanks for your response.

    So upon looking at services I do see the OpenVPN Service, but I'm unable to delete it using scdelete openvpn or sc delete openvpn (see attached picture).

    I've also verified that all the installation/config files have been removed from the Program Files location.  Any other suggestions?




  • On my Windows7 I have:
    OpenVPNService
    OpenVPNManager

    You probably need to use 1 or more of those names in "sc delete"



  • Using "sc delete openvpnservice" I was able to successfully remove the service.  However, again I tried to install the client export while running as admin, and it quickly speeds through the installation and says it's completed, but there's no trace of the OpenVPN GUI.  There IS a config file in Program Files (x86) > OpenVPN > config - but nothing else…not even in my Control Panel.  I feel like I'm going in circles trying to reinstall this program...



  • Anyone?  Am I really the only one with Windows 7 64-bit that is having this issue?  There has to be some way to completely remove any instances of the OpenVPN software and start from scratch.


  • LAYER 8 Global Moderator

    So your trying to install the x86 install from export client package?  the 2.2 or the 2.3?  Why don't you just download the 64bit install package from openvpn and then just use your config?

    http://openvpn.net/index.php/open-source/downloads.html

    Which reminds me - upon looking at the above url Im on 2.3.2-I001 while I003 is out ;)



  • To me, it sounds like something is broken on your WIN7 machine because NO - I don't think its acting like that for others.



  • Hey everyone,

    Here's a little update.  First of all, I have seen this issue on numerous Win7 64-bit clients.  I have seen it on at least 2-3 PC's at my work, and even my PC's at home.  OpenVPN acts very strange when you try to remove it sometimes.  What I ended up doing was downloading the client from another source and just using my own config file.  That seemed to do the trick.

    Thanks for your suggestions.


Log in to reply