Kernel Panic m_getzone: m_getjcl: invalid cluster



  • Hardware:
    AMD A10-5800K APU with Radeon™ HD Graphics
    4 CPUs: 1 package(s) x 4 core(s) (ASUS MB).
    Version:
    2.1-RELEASE (amd64)
    built on Wed Sep 11 18:17:48 EDT 2013

    Kernel panic message is:
    panic: m_getzone: m_getjcl: invalid cluster type
    cpuid = 0
    KDB: enter: panic



  • same error here when i boot without a keyboard - or with a keyboard through a KVM switch.

    only thing that works is having a keyboard connected directly.

    tried on two different socket 775 setups (different cpu,m/b & ram) and they both had this problem.

    both were 64bit 2.1 RELEASE versions.

    wierd bug…

    p.s never had this problem when i used pfsense from a vm with passthrough NICs.



  • Use boot option 3 each time your pfSense system boots.

    Or use option 8 to go to the console.
    In the console type:

    vi /boot/loader.conf.local
    Press Insert on your keyboard and start typing the following text (watch for typos!):

    hw.mca.enabled=0
    hw.bce.tso_enable=0
    kern.cam.boot_delay=10000
    Once done, press Escape on your keyboard and enter:

    :wq

    Continue by pressing Enter
    Reboot pfSense using the following command. It should now default to boot with USB support.

    shutdown -r now



  • thanks for your answer…

    After a few weeks after i posted the previous message - i have restarted pfSense (with the usb keyboard connected) and i somehow had another Kernel Panic with the same message, so i guess connecting that USB keyboard wasn't really the solution.

    After googling around i found that if i add

    "hw.pci.enable_msix=0"

    in the loader.conf should bring the system up to bootable state. And indeed it did, although i still keep the USB keyboard connected to have peace of mind.

    I'll keep your proposition at hand just in case i experience the problem again.

    Thanks again.


Log in to reply