IMspector plugin problem



  • Hello!

    I have a problem using IMspector with Pfsense 1.2-RC2
    I have installed the package succesfully.I've enabled it on lan if for msn and checked logging.
    But whenever i try to use it doing some chat from msn i see nothing on log window.
    I checked the system logs and the following messages appear:

    imspector: Error: Unable to communicate with logging process
    imspector: Connect socket, connect() failed to /tmp/.imspectorlog

    When i run it in debug mode i can see that it is filtering the messages but for some reason it does not write the log file…
    can you help please?

    I forgot to say that i have also squid in transparent mode enabled and ntop plugin running...

    thank you



  • Sounds like it can't write the file to the /tmp folder. Check the permissions of /tmp. It should be rwx for ugo and owned by root:wheel.



  • I am using 1.2-RC3 built on Tue Oct 16 04:22:39 EDT 2007 with the IMspector loaded! I have the same issues with the log display failure also! But I also question why when you look in services you have two instances running! Any idea how to resolve this matter!

    The only reason I loaded this is because of intermittent faulier of MSN Messenger on Vista while using PFsense, Snort, Squid, and the Traffic Shaper running!
    It is just strange behavior that cause the IMspector load….



  • thanks for your reply
    can you tell me which command i have to give on shell to change the permissions on /tmp folder?



  • I would've given detailed instructions in the first post, but I wasn't sure you needed them since you were able to start imspector in debug mode. Anyway type the following

    ls -l / | grep tmp

    Hmm I tired this on both machines and one that runs imspector is

    drwxrwxrwx  4 root  wheel      512 Oct 17 09:21 tmp

    My embedded box shows

    drwxr-xr-x  4 root  wheel      512 Oct 17 09:21 tmp



  • I think i have the same permissions but the problem still exist..any ideas?

    drwxrwxrwt  3 root  wheel        1024 Oct 19 11:57 tmp



  • @acidrop:

    I think i have the same permissions but the problem still exist..any ideas?

    drwxrwxrwt  3 root  wheel        1024 Oct 19 11:57 tmp

    you have a "t" in the last character .. i have the same problem how can change the permissions thanks !



  • I'm not sure if that is the problem. The t means that only the owner or root can delete the file or directory. Try changing it though as I know imspector drops its permissions.

    chmod 777 /tmp

    to change it back

    chmod 1777 /tmp



  • @rsw686:

    I'm not sure if that is the problem. The t means that only the owner or root can delete the file or directory. Try changing it though as I know imspector drops its permissions.

    chmod 777 /tmp

    to change it back

    chmod 1777 /tmp

    Thanks ! but still not working I saw this msg imspector: dlopen(): Shared object "libmysqlclient.so.15" not found, required by "mysqlloggingplugin.so"



  • I'm also having the same problem, this error shows up in my logs:

    imspector: Error: Unable to communicate with logging process
    imspector: Connect socket, connect() failed to /tmp/.imspectorlog
    

    I have tried to chmod 777 the files, which works fine, but the error still appears

    I do not have MySQL logging enabled, but I still also get the following error:

    imspector: dlopen(): Shared object "libmysqlclient.so.15" not found, required by "mysqlloggingplugin.so"
    

    This is with 1.2-RC3



  • naughtyusmaximus

    you should add manually.
    Look here for how to:

    http://forum.pfsense.org/index.php/topic,6416.msg36863.html#msg36863
    

    Cheers,



  • @rsw686:

    With the imspector package installed run the following from the console run

    pkg_info
    pkg_add -r mysql51-client

    and let me know the output and we can see how to proceed.

    I Had the same problem! TOO.

    It worked with me.
    Thanks for the solution and MORE Thanks toe everyone who posted the problem and insisted for the solution.

    .


Log in to reply