SquidGuard Time Restrictions not working ?



  • Hy,

    On my fresh 2.1 i386 box i install squidGuard and Squid.

    Filtering in non transparent mode is working.

    But it's look like the time restriction are not applied.
    I create a small list for sites denied in working time.

    Exemple :

    # ============================================================
    # SquidGuard configuration file
    # This file generated automaticly with SquidGuard configurator
    # (C)2006 Serg Dvoriancev
    # email: dv_serg@mail.ru
    # ============================================================
    
    logdir /var/squidGuard/log
    dbhome /var/db/squidGuard
    
    # 
    time horaire-bureau {
    	weekly * 08:30-12:30
    	weekly * 14:30-20:00
    }
    [...]
    acl  {
    	# 
    	sites-interdits  within horaire-bureau {
    		pass !in-addr !sites-interdits !blk_BL_porn !blk_BL_socialnet all
    		rewrite safesearch
    		log block.log
    		} else {
    		pass !in-addr !blk_BL_porn sites-interdits blk_BL_socialnet all
    		redirect http://192.168.10.10:80/sgerror.php?url=403%20&a=%a&n=%n&i=%i&s=%s&t=%t&u=%u
    		rewrite safesearch
    		log block.log
    	}
    	# 
    	default  {
    		pass !in-addr none
    		redirect http://192.168.10.10:80/sgerror.php?url=403%20&a=%a&n=%n&i=%i&s=%s&t=%t&u=%u
    		rewrite safesearch
    		log block.log
    	}
    }
    

    Sites are still blocked at 20:15.

    If i hit "Apply" in General Settings, sites are allowed and "porn" still blocked (what i want).

    I search on the forum, i found some people with same probleme but with no response…

    Can someone help us ?

    Thanks

    Guldil



  • I found this topic http://forum.pfsense.org/index.php?topic=59671.0 and i execute```
    /usr/local/sbin/squid -k reconfigure

    
    Time restriction are now applied and it's working as expected : i created some schedule 09:00-09:10, 09:20-09:30,  09:40-09:50 transitions are working.
    
    a bit strange right ?

Log in to reply