Como acessar dvr tec voz remotamente passando pelo pfsense?



  • Bom dia pessoal. Estou com um problema de acesso remoto.
    Instalamos o Pfsense aqui na empresa e não conseguimos mais acessar as câmeras remotamente. Ele serve o DHCP.
    Apliquei regras NAT com as portas que o DVR utiliza e nada. Toda vez que acessamos a nossa conta do ddns.com.br ela para na tela de login do Pfsense. Será que alguém poderia dar um help?
    Obrigado.



  • Olá!

    Se está caindo na tela do PFSense quando acessa de fora, com toda certeza o problema está nas regras de NAT Port Forwarding que você criou. Confira se elas apontam para o IP do DVR corretamente.



  • Olá Luiz, com certeza estou fazendo algo errado. As portas padrão do dvr são:

    1ª 3000 - imagem;
    2ª 3001 - pantilt, controle de imagem ;
    3ª 3003 - configurações;
    4ª 8800 - som;
    5ª 3007 - criptografia.

    No dvr, que é um PC com uma placa, existe o Direct Web, que é um aplicativo servidor de web, ou seja, nele é configurada a porta para o acesso á internet via browser. O padrão dele é porta 80. Criei as regras para essas portas com o IP fixo da dvr: 192.168.1.199. O firewall é o 192.168.1.254, que está como gateway no dvr. Não sei aonde estou errando. Se vc puder me ajudar, agradeço.



  • Poste um Print das suas regras de NAT>Port Forwarding.



  • Olá Luiz, desculpe a demora para postar, mas tivemos outras prioridades aqui e acabei postergando esse problema do acesso remoto das câmeras.
    Segue o print:




  • mude a porta do pfsense e desabilite o auto redirect rule em system advanced.



  • Senhores,

    Alguma solução para esse problema.. ?? quando o NAT esta em:

    Manual Outbound NAT rule generation (AON - Advanced Outbound NAT)

    a porta é 3000 de acesso e de tcp 2000. só que não esta funcionando..a visualização
    ele acessa mas não mostra video.



  • @gst.freitas:

    Alguma solução para esse problema.. ??

    O que o tcpdump te mostra?

    Ele vai poder responder a sua pergunta melhor que qualquer um aqui.



  • veja o tcpdump, lembrando que o meu ip 177.88.88.88 é da rede que estou acessando via internet adsl (mudei o ip)

    20:53:08.485098 IP 192.168.25.21.47048 > 221.231.140.160.15000: Flags [.], ack 1, win 2920, options [nop,nop,TS val 1403955 ecr 0], length 0
    20:53:08.487365 IP 192.168.25.21.47048 > 221.231.140.160.15000: Flags [P.], ack 1, win 2920, options [nop,nop,TS val 1403955 ecr 0], length 436
    20:53:08.509353 IP 177.88,88,88.53428 > 192.168.25.21.4000: Flags [.], ack 1, win 16560, length 0
    20:53:08.509423 IP 177.88,88,88.53428 > 192.168.25.21.4000: Flags [P.], ack 1, win 16560, length 383
    20:53:08.510140 IP 192.168.25.21.4000 > 177.88,88,88.53428: Flags [.], ack 384, win 3456, length 0
    20:53:08.540206 ARP, Request who-has 192.168.25.21 tell 192.168.25.21, length 46
    20:53:08.586841 IP 192.168.25.21.4000 > 177.88,88,88.53428: Flags [P.], ack 384, win 3456, length 16
    20:53:08.587222 IP 192.168.25.21.4000 > 177.88,88,88.53428: Flags [FP.], seq 17:205, ack 384, win 3456, length 188
    20:53:08.627605 IP 177.88,88,88.53428 > 192.168.25.21.4000: Flags [.], ack 206, win 16509, length 0
    20:53:08.628870 IP 177.88,88,88.53428 > 192.168.25.21.4000: Flags [F.], seq 384, ack 206, win 16509, length 0
    20:53:08.629339 IP 192.168.25.21.4000 > 177.88,88,88.53428: Flags [.], ack 385, win 3456, length 0
    20:53:09.981837 IP 192.168.25.21.47048 > 221.231.140.160.15000: Flags [.], ack 107, win 2920, options [nop,nop,TS val 1404104 ecr 376496565], length 0
    

    segue o nmap

    23/tcp   open  telnet
    554/tcp  open  rtsp
    2000/tcp open  cisco-sccp
    4000/tcp open  remoteanything
    
    

    em rede local a porta 554 é que fica estabilizada.



  • Este tcpdump mostra uma comunicação estabelecida. Não há neste log qualquer tentativa sem sucesso.

    Sugiro rodar o mesmo teste escutando na wan e lan(um terminal para cada tcpdump) para ver a comunicação antes e depois do nat.



  • o seu router adsl ta com nat nas mesmas portas para o pfsense? vc disse que sua rede é 192.168.1.X e o seu tcpdump ta mostrando ip 192.168.25.X ou seja, ta parando no seu router adsl aparentemente



  • Lucas,

    vc confudiu com a dúvida de outro colegas.. vc tem esse redicionamento ? tem como passar a rules.. a minha rede esta correta 192.168.25.x e o modem esta em modo bridge



  • verdade, misturei tudo.. rsrsrs
    nao tenho especificamente essa NAT, tenho outras funcionando, mais ja utilizei NAT com DVR em outras situacoes, lembro que precisei fazer NAT de portas UDP tambem senao nao mostrava video, era uma necessidade especifica do DVR que estava utilizando nao lembro agora qual a marca ou modelo dele


Log in to reply