WatchGuard FireBox x6500e



  • I recently gone one of these in good condition.

    However I can't get into the BIOS, nor does it looks like the BIOS flash is actually taking. I've followed the instructions, but…
    https://doc.pfsense.org/index.php/PfSense_on_Watchguard_Firebox#Flashing_the_BIOS

    Specifically, I know that it should take longer than 1-2 seconds to flash the BIOS usually, but it's coming back right away. And it should say the "pfSense B7" on the LCD screen but it's still got the Watchguard text, so I'm certain it's not taking.

    I've also booted into recovery, and verified that is is connecting properly at the 115200 baud rate, as per this thread:
    http://forum.pfsense.org/index.php/topic,20095.msg352111/topicseen.html#msg352111
    So it's definitely not a cable issue.

    And i'm using the 256MB CF card that came with it. Which is definitely booting into FreeDOS just fine.


  • Netgate Administrator

    You may have a different bios version and the awdflash is refusign to write. What does the biosid command report? I suggest that every time because it would be nice to find a newer bios but no one has yet found one.

    What command are you using in FreeDOS and what is the result exactly?

    Steve



  • It's the right BIOS version:

    
    BIOS DATA: 12/21/2005
    CHIPSET ID: Alviso
    BIOS ID: 6A79GAKAC-00
    BIOS TYPE: Phoenix Technologies, LTD.
    OEM Info: **** BIOS Ver.ETAC0017 (2005/12/21> ****
    

    However, the output doesn't have any line breaks, and is all on one line that wraps.

    and the command I've been using to try to flash is "awdcmd x750eb7.bin /py /sn /cc /e".
    I've tried b7 and b1, just to see if they work as well. b6 exhibits the same behavior. It sits for a second or two and then returns to the command prompt. b1 sits at the cursor as if something is going on, but after resetting it (after waiting 10+ minutes), it definitely has not flashed anything.

    Also, just on a hunch, trying to flash the backed up BIOS image exhibits the same behavior as the b1 BIOS image (hangs after flashing).


  • Netgate Administrator

    The command to flash the BIOS should be 'awdflash' not 'awdcmd'. Is that a typo?

    Steve



  • Yes, sorry, it was a typo. Definitely by using awdflash when using putty. Sorry.



  • Well, I was able to modify the PCI express 4x port to accept a video card… And the awdflash program is erroring out with a "Binary file is not Award BIOS".

    And on the backed up image, and the b1.bin, it errors out with "BIOS Image File Check Sum Error".


  • Netgate Administrator

    Hmm, well that's odd. I've never seen that error. How did you get the FreeDOS image? Did you download the BIOS file separately?

    The fact that it couldn't back up the old BIOS either doesn't look good. Perhaps the CF card is damaged? Did it boot the Watchguard OS ok?

    Steve



  • I downloaded the FreeDOS image from here: https://doc.pfsense.org/index.php/PfSense_on_Watchguard_Firebox#Flashing_the_BIOS
    I had actually redownloaded the image to make sure it wasn't a bad downloaded and still. I used physdisk to write the image to the CF card (the 256MB one that came with it).
    And seeing the boot screen, I can definitely confirm it's an Award BIOS, and matches the specs that BIOSID outputs.

    And it's not that it wouldn't backup the BIOS. That worked fine. It's trying to flash that backup that fails (invalid checksum), so yeah, I think the CF card may be bad.

    And I don't know if the Watchguard OS boots fine, actually. First thing I did was image FreeDOS to the card. However, the recovery mode (holding the UP button during boot) seems to work fine though.

    So it looks like I've really got two options here to proceed: Dig up another very small CF card, and hope it flashes, or build a keyboard header, which I'd rather avoid, as I suck at hardware modding. You wouldn't happen to have the pin layout for the keyboard connector, would you?

    And thank you very much for your time.



  • Is it certain that the x6500e have an Award Bios on them?



  • Yes. Absolutely certain.

    I've attached a few images to show exactly what's going on.
    Sorry, the "Awa" part is cut out of the AwardBIOS text, but you can clearly make the leap, as well as see the logo, where it isn't cut off by the "Input Select" box from my monitor.






  • Look at the 2003 copyright date!

    Looks a little newer than 1995…



  • Yes, and the BIOS version date is 2005…. And? According to the guide for flashing the BIOS for console redirection, that's what is expected, and wanted.

    And better point is why is AWDFLASH complaining about a non-award BIOS when it clearly is an Award BIOS...



  • @drashna:

    Yes, and the BIOS version date is 2005…. And? According to the guide for flashing the BIOS for console redirection, that's what is expected, and wanted.

    And better point is why is AWDFLASH complaining about a non-award BIOS when it clearly is an Award BIOS...

    Yep- and Im pointing out possible incompatibilities.  Hopefully you will be able to try a new CF card and see if thats the issue.

    As far as I know you are the first to try Steve's bios on this model. Watchguard people have been telling people I know and work with that they have the bios locked down in newer models. It would be good to know if this is just hype from sales people or true.

    Allot of the watchguard modding here is still experimental.



  • Well, as I said, the BIOS ID information appears to be the correct model. Not sure.  And I don't have a spare CF card that isn't 4GBs.

    And either way, the PCIe 4x slot works for an older VGA card I have, and i've ordered a ps2 to header cable, so when that arrives, I'll see about accessing the BIOS. I'd rather have direct access, even if it's completely inconvient. Once I get it booting pfSense, I shouldn't need to hook up the vga card again.


  • Netgate Administrator

    You are not the first to try this. I have an X5500e here and others have also flashed X-peak-e models. They have an identical motherboard to the x-core-e models.

    The newer models, xtm5 xtm8 etc, do have a locked BIOS in as far as you can't change any settings by default. However its not encrypted and doesn't prevent loading an alternative OS. It can be unlocked.

    Steve



  • That's what I thought.

    I'm just weird-ed out by the fact that it won't flash, and the errors it is giving.
    But that's part of why I don't like messing with hardware.  Something weird always seems to hit me. And I'm sure if I was doing this for somebody else… it would have worked just fine... That's how my luck goes.


  • Netgate Administrator

    Ha, well you may be unlucky and this is certainly not a common error but I'm sure it can be overcome.  :)

    Steve



  • Thanks, and thank you for your time.  :)

    And as I said, I've ordered a ps2/keyboard header, and hopefully that will solve/work around the issue.

    Either way, I'll post the results when I get the keyboard header.



  • weird i had no issues with a full hdd mod on my x5500e as expected and non on my x6500e as well, i just transfered HDD from on to another when using 2.0.3 and then when testing the 2.1 RC's and then running 2.1 REL



  • Well, I got the header… but as I said, I suck when it comes to anything hardware related. I was rewiring the header, when halfway through, I realized that I'd messed up... and don't remember which pins were which or should go were. And I lack a voltage meter to test this out....


  • Netgate Administrator

    Pretty sure it's standard, same as the x-core box:
    http://forum.pfsense.org/index.php/topic,20242.0.html

    Steve



  • Oh,  that I don't have an issue with. It's just that I don't know which wires go to which pins. And the actual ps2 connector is covered in hard plastic, so taking it apart would be a PITA.

    I hate to keep on asking for such "basic" help, but …. my dislike of hardware, my luck luck with it, and my lack of experience with it all kind of feed each other.
    But you wouldn't happen to know which of wire is which by color? (red, green, brown and yellow).

    And again, thanks for all of your help. It has definitely been appreciated.


  • Netgate Administrator

    Ah. No idea I'm afraid. Could be standard though I suppose.

    Steve



  • I had to literally tear apart the connector housing for the PS2 port, but as it was $5, and basically only being used for this, I didn't see an issue.

    But I got it working! Got into the BIOS, configured the CF card, and booted.

    stephenw10, thank you for all your help! It is definitely appreciated!

    And specifically the ps2 header I got was this one:
    http://www.pccables.com/06010.html

    And in case anyone else needs it,
    pin 1: green,
    pin 2: brown,
    pin 4: red,
    pin 8: yellow,

    At least, for the cable I got, that's what worked.


Log in to reply