No CPU Temperature



  • Hello,
      I can't monitor the CPU temperature using pfSense version 2.1 Release (i386) (upgraded from version 2.0.3).
    The PC is a HP DC 7700 (Intel Pentium D 945 Processor (3.4-GHz, 2x2MB L2 cache, 800-MHz FSB))

    What I did is:

    1. Add coretemp_load="yes" to the file loader.conf.local
    2. Set System/Advanced/Misc/Thermal Sensors to "Intel Core …"

    but the widget on the dashboard says "No Thermal Sensors data available.".

    I was trying to dig a little bit, and when I run from the console:

    kldload coretemp
    

    I get a:

    kldload: can't load coretemp: File exists
    

    and that should mean that the module has already been loaded.

    If I run:
    sysctl -a | grep temperature
    I just get no results… :S

    When I boot pfSense on that machine I see:

    Sep 27 09:03:36	kernel: Origin = "GenuineIntel" Id = 0xf64 Family = f Model = 6 Stepping = 4
    Sep 27 09:03:36	kernel: CPU: Intel(R) Pentium(R) D CPU 3.40GHz (3389.06-MHz 686-class CPU)
    ...
    Sep 27 09:03:36	kernel: Features2=0xe49d <sse3,dtes64,mon,ds_cpl,est,cnxt-id,cx16,xtpr,pdcm>Sep 27 09:03:36	kernel: Features=0xbfebfbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>...
    Sep 27 09:03:36	kernel: p4tcc1: <cpu frequency="" thermal="" control=""> on cpu1
    Sep 27 09:03:36	kernel: est1: <enhanced speedstep="" frequency="" control=""> on cpu1
    Sep 27 09:03:36	kernel: p4tcc0: <cpu frequency="" thermal="" control=""> on cpu0
    Sep 27 09:03:36	kernel: est0: <enhanced speedstep="" frequency="" control=""> on cpu0
    ...</enhanced></cpu></enhanced></cpu></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe></sse3,dtes64,mon,ds_cpl,est,cnxt-id,cx16,xtpr,pdcm>
    

    Anyone can figure out why I can't monitor the CPU Temperature?

    Thanks,
    Michele


  • Netgate Administrator

    The Pentium D was still based on the Netburst architecture and the coretemp module only works with Core based CPU.

    You would have to try to use mbmon to read temperatures. There are a few threads about intergrating it's output with the dashboard widget.

    You may be able to read the ACPI temperature. Is it enabled in the bios?

    Steve



  • Hi Steve,
    thank you for your answer… unfortunately both solutions didn't work...

    mbmon -c1
    returns

    No Hardware Monitor found!!
    InitMBInfo: No error: 0
    

    and
    sysctl -a | grep therm
    or
    sysctl -a | grep temper

    return no results… :(

    Ok, I got it, I will upgrade my firewall sooner or later... :D

    EDIT: and yes, ACPI is enabled in the BIOS setup, and recognized during the boot... (ACPI APIC Table: <compaq broadh2o="">)

    Thanks,
    Michele</compaq>


Log in to reply