IPv6 IP does not get assigned on PPPoE WAN in 2.1-release



  • I am currently using an older pfSense beta:

    2.1-BETA0 (i386)
    built on Tue Jun 5 22:51:01 EDT 2012

    In there IPv6 and IPv4 works perfect over a PPPoE DSL interface. My provider does native IPv6.

    Currently my pppoe0 configuration looks like this (IPs changed):

    pppoe0: flags=88d1 <up,pointopoint,running,noarp,simplex,multicast>metric 0 mtu 1492
    inet6 fe80::3079:1559:f514:b935%pppoe0 prefixlen 64 scopeid 0xb
    inet xx.yy.156.18 –> xx.yy.128.206 netmask 0xffffffff
    inet6 2xxy:aaaa:4:9c12:3079:1559:f514:b935 prefixlen 64 autoconf
    nd6 options=3 <performnud,accept_rtadv>Now I prepared another card with 2.1-release, unfortunately I can't get an IPv6 address like this, v4 gets assigned properly. I also tried the (in my beta not available) option to get the v6 address over v4 but doesn't seem to change it.

    Am I missing something?

    thanks

    Adrian</performnud,accept_rtadv></up,pointopoint,running,noarp,simplex,multicast>



  • Hi,

    I am having the same issue.

    Currently no one official has said anything about this or upcoming fixes. but here is a temp one.

    Since you know the cli type netstat -rn
    this will list the routes for both ipv4 and ipv6 in the ipv6 area you will see it is as something like this …
    Internet6:
    Destination                      Gateway                      Flags      Netif Expire
    default                          feX0::90:XX00:243:feXXX%vr1    UGS        vr1 (notice it's pointing to the actual interface in my case vr1 not the pppoe that comes up?) Copy paste  everything under the gate way section up to the % and add your pppoe interface  your using. then type this command. Filling in the rest with your gateway info.

    route change -inet6 default feX0::90:XX00:243:feXXX%pppoe0

    Hope this helps.



  • Hi,

    Thanks for the hints, interestingly enough the default route seems to be set properly now:

    default      fexx::yy:a9ff:fe86:f01b%pppoe0 UGS      pppoe0

    I am pretty sure this was not the case last time I tried as I couldn't ping6 anything. Now IPv6 connectivity works on the clients so seems to be fine.

    However, it does not show up in pfSense itself:

    WAN (wan)      -> pppoe0    -> v4/PPPoE: xx.yy.156.18/32

    The webinterface does not show IPv6 either on the WAN interface.

    So it somehow works and somehow not :-)

    Thanks for the hints!



  • In this case you should check the "Use IPv4 connectivity as parent interface" option.

    Regarding the WAN address display issues, I have pointed out the issue to the devs in one of the bug reports some time before release, but I guess it was not fixed in time.


Log in to reply