NAT Reflection in 2.1 release… Seems to be working 100% now.



  • So, my NAT reflection has been broken for as long as I can remember for UDP in the past and only TCP NAT reflection has worked for me.

    So - For 2.1 I decided to play with it once again.  (In case something has changed. )

    I tried a variety of things that sort of worked and failed at other times, but in the end what works for me is:

    System > Advanced > Firewall / NAT

    NAT Reflection mode for port forwards - NONE

    Then, in Firewall > NAT:

    For every TCP port forward, I use NAT reflection - NAT + Proxy
    For every UDP port forward, I use NAT reflection - Pure NAT

    This seems to give me reliable UDP NAT reflection and Reliable TCP NAT reflection.

    I don't know why this combination works, but I like it.
    Any other way, seems to break one, the other or both for me.

    SIP UDP NAT reflection works and so does my UDP VPN (Not that I need it inside the LAN)
    The only thing that hasn't worked so far is IAX2 (not that I need it) but that may be a server issue.

    EDIT:  I later also set Enable automatic outbound NAT for Reflection on under:  System > Advanced > Firewall and NAT
    Now everything works, including IAX2



  • I realize this is old but have you tried the UDP nat reflection with 2.2 beta yet?  When I try using it and sending UDP packets from the LAN to the outside IP the reflection isn't working properly.  I am wondering if this is a 2.2 thing or something else is causing it.



  • Blast from the past….

    No - I have not.  I'm not in a good position to run Beta releases in production.

    I think for sure others have.  Perhaps they will reply.


Log in to reply