No-IP only manually updating post 2.1



  • My router didn't seem to have this problem before 2.1 upgrade.

    Now when my ISP changes my WAN IP, I have to go into the setup and manually restart and update.

    Is there a way to set it to update automatically?



  • Setup the Wan adapter?  DHCP or fixed IP?  What parameters in the Wan settings change and which don't you want to change, just the IP addy?



  • encounter the same as mentioned in the below thread
    http://forum.pfsense.org/index.php?topic=53793.0

    "the cached IP within the GUI shows in red and is in fact the old IP given by the ISP. When checking the dashboard I can see that "Current WAN IP" is correct within the logfile, but somehow pfsense doesn't manage to update to the new IP properly."

    This thread provided a workaround for such issue
    http://forum.pfsense.org/index.php?topic=58034.0

    My log as below, it shows that pfsense detected the ip change (new ip xx.xx.xx.xx) but fail to update the dynamic DNS

    Oct 17 05:14:34 php: rc.newwanip: Curl error occurred: Could not resolve host: members.dyndns.org
    Oct 17 05:14:05 php: rc.newwanip: ROUTING: setting default route to xx.xx.xx.xx
    Oct 17 05:14:05 php: rc.newwanip: rc.newwanip: on (IP address: xx.xx.xx.xx) (interface: wan) (real interface: yyy).
    Oct 17 05:14:05 php: rc.newwanip: rc.newwanip: Informational is starting yyy.
    Oct 17 05:14:03 check_reload_status: rc.newwanip starting yyy


  • Netgate Administrator

    Hmm, I've just encoutered this problem myself. I'm also using No-IP and am seeing this in the logs:

    php: rc.dyndns.update: Curl error occurred: Could not resolve host:
    

    2.1 is able to use dyndns on multiple WAN connections, 2.0.X was not. Perhaps it is confused about which connection it should be using. Also when upgrading my WAN interface changed names from WAN to WAN_PPPOE. This is a transparent change in most areas but I wonder if it is causing a problem here.

    Steve



  • I have the same problem, different DNS Services.

    Setup:
    2.1 Release (i386)
    Dynamic DNS -> NameCheap
    Dynamic DNS -> DynDNS (Dynamic) Paid/VIP member
    Spoofed WAN MAC
    FiOS Dynamic IP
    Squid3 bound to LAN only - NOT Transparent mode
    Squidguard
    Unbound

    What happens:
    Updates to NameCheap and DynDNS yield the following error

    php: rc.dyndns.update: Curl error occurred: Could not resolve host:
    

    What I tried:

    1. Executing /usr/bin/nice -n20 /etc/rc.dyndns.update in a shell - Same Result

    I ran a WAN packet capture during the update process.  DNS resolves OK but then I don't see any attempt to reach either Dynamic DNS service.

    1. Save+Force Update to just NameCheap -> Success

    2. Run /usr/bin/nice -n20 /etc/rc.dyndns.update again.
      NameCheap update process works properly.  DynDNS update fails with the same error.

    3. Read every post I could find and tried stuff like switching Gateway/Monitor IP and changing the Cron for /usr/bin/nice -n20 /etc/rc.dyndns.update to  */15 *  * * *

    I'm out of ideas, wondering if this a bug.
    Thanks.


  • Netgate Administrator

    Hmm, having manually updated by save+force update I am no longer seeing the problem.

    IPv4/v6 problem? https://doc.pfsense.org/index.php/Controlling_IPv6_or_IPv4_Preference

    Steve


Log in to reply