[SOLVED] IPSEC not tunneling traffic



  • I'm on pfSense 2.1 and I just followed the guide (https://doc.pfsense.org/index.php/Mobile_IPsec_on_2.0) to setup an VPN Tunnel back to my pfSense. I can connect and get to local machines. I've setup my iPhone ipsec vpn and it connects, also on latest ios 7.0.2

    However its not routing all traffic over the tunnel, is there something I missed to force all traffic back over the VPN tunnel?

    Thanks!



  • I use iPhone to PfSense via OpenVpn works well. The OpenVpn server tab has a checkbox for "force all client generaged traffic thofugh tunnel".  Might check that IPSec server tab offers the same parameter.



  • Thanks markn62, I had openvpn already setup and its working great. I didnt think about looking for an app in the store.

    I still would like to know why it isnt tunneling.



  • Did you find a similar checkbox in the IpSec tab?

    @markn62:

    I use iPhone to PfSense via OpenVpn works well. The OpenVpn server tab has a checkbox for "force all client generaged traffic thofugh tunnel".  Might check that IPSec server tab offers the same parameter.

    What tunnel related errors are you getting in your IpSec or General system log?

    The UltraVpn (GuizmoVpn) iPhone app makes setting up the client very easy.  If you already have OpenVpn server setup I'd go that route.  More secure, always stays connected, can auto the tunnel to not be enabled on WiFi with xyz SSID yet connect the tunnel while on all other WiFi's and 3G connection.  Slick…



  • Tunnel is set on the ipsec page, but really not worth finding out whats causing the issue when the openvpn is working great.

    Thanks for the help



  • Presume you set iPhone VPN configuration "SEND ALL TRAFFIC" to "ON".

    This is a good resource for OpenVpn client setup.
    http://www.guizmovpn.com/index.php?option=com_agora&task=topic&id=559&Itemid=14


Log in to reply