No squid.conf (squid3) on pfsense 2.1



  • Hi to all,

    This is my first post so if I post in a wrong forum, please forgive me.

    My concern is I want to edit the squid.conf on the /usr/local/etc/squid folder but unfortunately, i cannot found the file squid.conf.

    I also tried to install a new copy of PFSense 2.1 and download again the squid3 package but the same error (no squid.conf).

    But when I use the PFsense 2.0.3, the squid.conf is there. Hope you could help me on this.

    One more thing, I noticed in PFSense v2.1 that the Interfaces from squid3 and dansguardian are still OPT1 and OPT2 eventhough i changed it to Technical & Sales interfaces. Is there any patch or update to chaged it like on v2.0.3.

    Thanks again.

    PFsense Version:
    2.1-RELEASE (i386)
    built on Wed Sep 11 18:16:22 EDT 2013
    FreeBSD 8.3-RELEASE-p11

    Packages:

    • Squid3, Dansguardian, Squidguard, Sarg, Freeradius2.


  • Squid.conf on 2.1 is under /usr/pbi/squid-i386/etc

    The interface alias is a bug on 2.1 package framework.  I'll pull request a fix today.

    It will be a patch until 2.1.1



  • here is the patch
    you can apply it using package System Patches
    patch id = f82cbe4

    or download the file with this cmd

    fetch -o /usr/local/www/pkg_edit.php https://raw.github.com/pfsense/pfsense/RELENG_2_1/usr/local/www/pkg_edit.php
    


  • Hi Marcello,

    Will this patch also fix display of the alias in the postfix package or is it just for squid?

    Thanks



  • On all packages.



  • Thanks marcelloc, you're the best.  ;)

    I will try the patch and see if it will work. I will update you once I apply the patch.

    One more thing, The squid3 Captive Portal patch sometimes work and sometimes doesn't. Is there any patch or solution to let  Squid3 and Captive Portal work together?

    Thanks a million. Cheers.

    Emong.



  • Many thanks, once again, Marcello.  :)



  • I do have a local website (owncloud) that I do not want to be cached. Was thinking of adding an "include" in the squid.inc file so everytime the package gets reloaded / changed by pfsense the cache deny all will kick in for that specific site. Where can I set that up?

    So, in sum it the squid.inc will always overwrite the squid.conf, so in the squid.inc add an include cache_exceptions.conf with cache deny all for the sites I don't want cache enabled. How can that be accomplished?


Log in to reply