Sarg wrong path to log files?



  • Hi I upgraded from pfsense 2 to 2.1 and experienced problems with bandwidthd it stopped graphing and Sarg it stopped running reports.

    I followed some other posts and had to upgrade png and some other files and then reinstalled bandwidthd to get it working.

    I can't seem to get Sarg running though. Its pointing at the wrong location for squid log files. It should be /var/squid/logs/access.log

    Any ideas? thanks

    php: /pkg_edit.php: The command 'export LC_ALL=C && /usr/pbi/sarg-i386/bin/sarg ' returned exit code '1', the output was 'SARG: File not found: /var/log/squid/access.log'



  • Heres the answer http://forum.pfsense.org/index.php/topic,47765.0.html

    for whatever reason you have to modify the sarg conf file and modify the path to the log files /usr/local/etc/sarg/sar.conf.default

    Will that be fixed in another release? thanks



  • Can it be compiled to use graphs?

    php: /pkg_edit.php: The command 'export LC_ALL=C && /usr/pbi/sarg-i386/bin/sarg ' returned exit code '1', the output was 'SARG: (info) No graphs available as sarg was not compiled with libgd. Set "graphs" to "no" in /usr/pbi/sarg-i386/etc/sarg/sarg.conf to disable this warning SARG: Unknown value "hide" for parameter "realtime_unauthenticated_records"



  • I've changed build options and asked a compile run last week, I'll do it again today.



  • ok that would be great. thanks


Log in to reply