Package hell fighting with Sarg, Squid & Bandwidthd please help!



  • Hi I really need pfsense to work with Sarg, Squid and Bandwidthd. I really don't care which versions.

    I upgraded from pf 2xxx to 2.1 and I just can't get anything running. I really need this since we have very limited bandwidth (20 GB) a month with three teenagers if you get my point….

    Seems like all three packages use conflicting versions of png & jpeg ect. I resolve the dependencies for one and break the other! Help!

    I don't think reinstalling the old version of pf would work either since its still going to download the packages from the latest sources I believe?

    See error

    [2.1-RELEASE][root@firewall.home.net]/root(12): pkg_add -r -f http://files.pfsense.org/packages/8/All/bandwidthd-2.0.1_5.tbz
    Fetching http://files.pfsense.org/packages/8/All/bandwidthd-2.0.1_5.tbz… Done.
    pkg_add: warning: package 'bandwidthd-2.0.1_5' requires 'png-1.5.14', but 'png-1.4.8_1' is installed
    pkg_add: warning: package 'bandwidthd-2.0.1_5' requires 'jpeg-8_4', but 'jpeg-8_3' is installed
    pkg_add: warning: package 'bandwidthd-2.0.1_5' requires 'freetype2-2.4.11', but 'freetype2-2.4.7' is installed
    pkg_add: warning: package 'bandwidthd-2.0.1_5' requires 'gd-2.0.35_8,1', but 'gd-2.0.35_7,1' is installed
    pkg_add: warning: package 'bandwidthd-2.0.1_5' requires 'libiconv-1.14', but 'libiconv-1.13.1_1' is installed
    [2.1-RELEASE][root@firewall.home.net]/root(13): pkg_delete png-1.4.8_1
    pkg_delete: package 'png-1.4.8_1' is required by these other packages
    and may not be deinstalled:
    gd-2.0.35_7,1
    sarg-2.3.2
    sarg-2.3.2
    sarg-2.3.2_4
    sarg-2.3.1
    sarg-2.3.2
    sarg-2.3.2_4
    sarg-2.3.6_2
    sarg-2.3.2_4
    bandwidthd-2.0.1_6
    bandwidthd-2.0.1_6
    bandwidthd-2.0.1_6
    bandwidthd-2.0.1_5



  • On 2.1 packages are "chrooted" with pbi build to avoid these lib conflit.

    Why are you using pkg_add to install them instead of interface package manager? ???



  • I have been adding them via the GUI package manager until 2.1 where I started having problems. Then I started reading other posts where adding them via pkg_add was the solution.

    I did read about 2.1 isolating lib files to avoid conflicts which sounds great. So when I look at available packages even though its not written for 2.1 will the OS still isolate the files?

    So how would I go about cleaning this up and reinstalling from the PBI? thank you



  • The best cleanup is a firewall reinstall and backup restore as pkg_add install a lot of things.

    The pfsense version you see on package list are minimal version. It should work from 2.0 to 2.1



  • yikes ok lesson learned! thank you



  • I'm pleased to report that reinstalling the OS and restoring the config has resolved the issue! thank you



  • Great!  :)


Log in to reply