Problemas com Varnish na ultima versão Pfsense



  • Ola atualizei o pfsense..e no entanto o varnish não inicia. Há alguma incompatibilidade do varnish com a ultima versão do pfsense?



  • Tem alguma informação a mais?
    alguma tela de erro durante o boot?
    log de sistema?
    já tentou subir ele pela console?



  • Ola pelo console fiz o seguinte:
    comando:  /usr/local/etc/rc.d/varnish.sh start

    e ocorre o seguinte:

    kern.ipc.nmbclusters: 65536
    sysctl: kern.ipc.nmbclusters: Invalid argument
    kern.ipc.somaxconn: 16384 -> 16384
    kern.maxfiles: 131072 -> 131072
    kern.maxfilesperproc: 104856 -> 104856
    kern.threads.max_threads_per_proc: 4096 -> 4096
    nm: not found
    Message from C-compiler:
    exec: cc: not found
    Running C-compiler failed, exit 2

    VCL compilation failed



  • Devem estar falando algumas dependências na compilação do pbi.

    Vou testar por aqui, atualizar as dependências e solicitar nova compilação.



  • Bom dia,

    Alguma novidade?
    Estou com problema aqui também, acontece o mesmo problema

    kern.ipc.nmbclusters: 65536
    sysctl: kern.ipc.nmbclusters: Invalid argument
    kern.ipc.somaxconn: 16384 -> 16384
    kern.maxfiles: 131072 -> 131072
    kern.maxfilesperproc: 104856 -> 104856
    kern.threads.max_threads_per_proc: 4096 -> 4096
    nm: not found
    storage_malloc: max size 512 MB.
    Message from C-compiler:
    exec: cc: not found
    Running C-compiler failed, exit 2
    VCL compilation failed



  • Já alterei os parametros de compilação do varnish para incluir o gcc no mesmo pbi do varnish, agora é só esperar o Jimp compilar para testarmos.



  • Obrigado.
    Meu pfsense de produção está parado por causa do Varnish.


Log in to reply