HTTP/HTTPS Traffic Going Into P2P Queue



  • Hello, all!

    I finally got around to working on the traffic shaper… However, I have run into a problem. I went through the wizard, and here are the settings for it:

    There are: 1 WAN (1 physical interface) and 5 LAN (1 physical interface, 5 logical interfaces with 5 separate VLANs).
    It is set up with CBQ, with the following priorities: qVOIP=7, qACK=6, qOthersHigh=4, qOthersLow=3, and qP2P=2 (qP2P is the default queue).

    The problem is, for some reason HTTP and HTTPS traffic is being shuttled into the qP2P queue, rather than the qOthersHigh queue (as is specified in firewall rules under "Floating").

    (I determined this by looking in the Queues tool. All of the active VLANs had almost no traffic in the qOthersHigh, while P2P was pegged. To confirm that people weren't just torrenting or something, I used an unused VLAN (computer lab) to test this. It had absolutely no traffic, then when I loaded webpages on five computers simultaneously the qP2P queue jumped up, while qOthersHigh remained dormant).

    I did a package capture of a computer that was doing nothing but loading a webpage, and here is the outcome:

    23:00:50.756880 IP 74.125.239.103.80 > 192.168.3.115.49275: tcp 1460
    23:00:50.756908 IP 74.125.239.103.80 > 192.168.3.115.49275: tcp 1460
    23:00:50.756926 IP 74.125.239.103.80 > 192.168.3.115.49275: tcp 1176
    23:00:50.756988 IP 74.125.239.103.80 > 192.168.3.115.49275: tcp 1460
    23:00:50.757187 IP 192.168.3.115.49275 > 74.125.239.103.80: tcp 0
    23:00:50.757232 IP 74.125.239.103.80 > 192.168.3.115.49275: tcp 1460
    23:00:50.757253 IP 74.125.239.103.80 > 192.168.3.115.49275: tcp 1460
    23:00:50.757272 IP 74.125.239.103.80 > 192.168.3.115.49275: tcp 1450
    23:00:50.757432 IP 192.168.3.115.49275 > 74.125.239.103.80: tcp 0
    23:00:50.757446 IP 192.168.3.115.49275 > 74.125.239.103.80: tcp 0
    23:00:52.247229 IP 74.125.239.103.80 > 192.168.3.115.49275: tcp 1460
    23:00:52.247256 IP 74.125.239.103.80 > 192.168.3.115.49275: tcp 1189
    23:00:52.247457 IP 192.168.3.115.49275 > 74.125.239.103.80: tcp 0
    23:00:52.249826 IP 192.168.3.115.49275 > 74.125.239.103.80: tcp 748
    23:00:52.249905 IP 74.125.239.103.80 > 192.168.3.115.49275: tcp 0
    

    I also did it a couple other times, and the port (in this one, 49275) was different. So, it looks like the port on this end is shifting from one use to the next…

    Any idea what could be causing this/how to fix it? I even added firewall rules for the ports that Squid redirects to for HTTP and HTTPS).

    Thanks!
    ElectroPulse



  • Any traffic not matching a rule will automatically go to the default queue.  Change the default rule "checkbox" from qP2P to qDefault is step #1.  Can only have one default queue.  Step #2 is reviewing your rules that they are getting hits rather than going to the default queue.


Log in to reply