Local httpd



  • Hello,

    I have a httpd with a domain name xxx.com the http have ip adress 192.168.1.2 everything work perfect from outside (officel ip adress port 80 forwarded to 192.168.1.2).
    But when I try to browse my domain name from my computer on the same subnet have I problem to connect….

    How can I solve this? I have not had this problem with my old linksys router.

    Thank you for respons.


  • Rebel Alliance Global Moderator

    So your trying to go to www.xxx.com that resolves to your public IP from behind pfsense?  You need to enable nat reflection to do that.  Or better method is to have your local hosts directly resolve www.xxx.com to your private IP 192.168.1.2



  • @johnpoz:

    So your trying to go to www.xxx.com that resolves to your public IP from behind pfsense?  You need to enable nat reflection to do that.  Or better method is to have your local hosts directly resolve www.xxx.com to your private IP 192.168.1.2

    Thank you for using time on me problem. I wil l try to explain another way:

    xxx.com  - offical IP adress 166.54.223.2 (example).
    httpd server have 192.168.1.2 (local network)

    I have port forwarding on 166.54.223.2 on port 80 to 192.168.1.2 port 80

    When people use xxx.com they are abel to reach my httpd server,
    but when I try from my computer who are into the same subnet I can`t connect.
    It must have something with the DNS server todo?

    I hope you understand me here :)



  • You need to enable nat reflection to do that.  Or better method is to have your local hosts directly resolve www.xxx.com to your private IP 192.168.1.2

    This is the answer - do one of these. An easy way is to add a host override in DNS Forwarder to define xxx.com to be 192.168.1.2



  • @phil.davis:

    You need to enable nat reflection to do that.  Or better method is to have your local hosts directly resolve www.xxx.com to your private IP 192.168.1.2

    This is the answer - do one of these. An easy way is to add a host override in DNS Forwarder to define xxx.com to be 192.168.1.2

    It is like phill said, I had the same issue here, the workqround was enabling DNS Forwarder to resolve the host and domain to my internal IP from my internal machines.

    On your case see attached.

    Hope it helps. Regards.



  • Rebel Alliance Global Moderator

    Phil just quoted and agreed with what I said ;)  But sure give phil the credit!! rofl





  • @adolfo_rodrigues:

    @phil.davis:

    You need to enable nat reflection to do that.  Or better method is to have your local hosts directly resolve www.xxx.com to your private IP 192.168.1.2

    This is the answer - do one of these. An easy way is to add a host override in DNS Forwarder to define xxx.com to be 192.168.1.2

    It is like phill said, I had the same issue here, the workqround was enabling DNS Forwarder to resolve the host and domain to my internal IP from my internal machines.

    On your case see attached.

    Hope it helps. Regards.

    It is working, thank you very much!

    I have many vhost like test.xxx.com bla.test.com etc… Can I set up so every vhost work also?
    I have tested it works to add manually each vhost, but is their a way I can take all at the same time?