Problems with utorrent



  • basically, when I open utorrent, I'm getting intermittent internet connection, but if its off, the problem is gone.

    I finally found this problem after about a month of isolation and I bet the DSL provider is already sick of my intermittent connection calls lol. either way, how can I fix this? this really took me SOOO long to find out.

    going to services -> upnp & NAT isn't doing me anything.

    to explain my network structure:

    dsl modem = 192.168.1.1
    pfsense wan = 192.168.1.10
    pfsense lan = 192.168.0.1 (gateway)
    diskless client computers: 192.168.0.101 - 192.168.0.112

    my server pc running the virtual box pfsense and diskless server has 2 NICs. one is connected to the dsl and the other connected to the switch network. IP connected to switch is 192.168.0.100 (bridged to pfsense LAN as well) while the other NIC connected to dsl has no IP (no read from win7) and pfsense uses it as WAN port with IP 192.168.1.10.

    You probably guessed it. I'm running a net cafe.

    how can I open utorrent without ruining the internet?



  • I wonder if I already solved my problem

    utorrent:

    1. preferences -> connections -> enable UPnP
    2. used 27777 as constant port (not gonna random)

    pfsense GUI:

    1. Firewall -> Rules -> add rule
    2. destination port range: 27777
    3. target IP: 192.168.0.100



  • nooo I didn't fixed it.



    I probably missed something but I don't know what. This isn't happening to me even if I use IDM to direct download.



  • What you need is to create a  NAT port forwarding rule to forward all incoming connections on your WAN at port 27777 to your PC's internal address. I would disable uPnP.



  • already had it.



  • If you mean that your browsing gets slow when uTorrent is downloading/uploading, well, it's fine and expected. You will need to configure the traffic shaper to overcome that.

    Or put a cap on the uTorrent download and upload bandwidth on the program itself.



  • ^

    I already limited utorrent DL/UL speed

    my torrents are all in seeding mode and I even capped it at 1 seed at a time.

    when I pause utorrent the internet is fine

    I can say this with certainty thanks to ping command.

    ping command:

    1. press windows key + R
    2. ping www.google.com -t
    3. monitor for about 3 minutes



  • Strangely, when I use Gnutella and limit the uploads/downloads in the program its self to about 60% of my total capacity my internet actually works better than if there is no load on the connection at all.  Part of the problem might be in your latency settings for your gateway monitors.  I've never had to change my settings on FIOS, but I wonder what would happen if you change the latency settings?

    I'm not sure of all the actions that pfsense takes when it thinks connectivity has been lost, but just to be sure, I'd raise those latency settings and give it another try.  Latency will increase when you are using P2P.



  • To be able to browse, you need a fair amount of UPLOAD available as well. How much is your bandwidth and where did you set the limits?

    You could also be having a problem with the amount of simultaneous connections, I guess. Or could be the ISP. This is strictly not a problem from pfSense as I see it. I think the torrent software is clodging your bandwidth. Again, you could probably overcome it by properly configuring the traffic shaper



  • I considered that it could be a problem with the limit to max states on some piece of hardware, bit if pfsense is doing all the routing and grabbing the public IP on its WAN, that shouldn't be an issue.

    I figure his latency settings on WAN monitor or he is being throttled to death by the ISP.



  • speedtest.net tells me that my DL is 2.5mbps and UL is 0.75mpbs. haven't used pfsense traffic shaper yet.

    in my utorrent I limited DL to 150kb/s and UL at 10kb/s. (kilobytes, not bits)

    I think those numbers are pretty reasonable, and I never had this big problem (intermittent connection) back when I was still using my old D-link router. I don't' remember configuring anything special in my old D-link router.

    And even back then my network isn't gigabit yet. Only now that I switched to diskless environment I needed a gigabit network. Some of my customers said they're getting frequent disconnection from one game (crossfire) but my other set of customers playing LoL didn't get disconnected games (or maybe few, but nothing worthy of mention)

    but when I bought a NIC and switched to pfsense only then I had this problem.

    I never got to solve the network problem from the utorrent.



  • Dlink is a stupid simple router.  It wouldn't have some of the features that might get you in trouble, but it also doesn't have features you want.  So, I take this to mean you have no intention of trying adjusting latency settings?

    Cool - Enjoy.



  • ^ Agreed that d-link is very simple and its features are too few compared to pfsense. It did the job, but no doubt pfsense will do better than d-link once I configured this properly.

    for now I just want utorrent to not disturb my internet performance (evidence in ping command) while I'm downloading / seeding something. skip the latency thingy for me until I needed the more advanced features of pfsense.



  • btw, i tried enabling / disabling the upnp and NAT from services tab.

    update:

    I've added port 27777 in the LAN and WAN rules. destination is LAN and WAN address respectfully. protocol being TCP/UDP.

    port forward: protocol is TCP/UDP, destination is WAN address. dest. port is 27777, target IP is 192.168.0.100. NAT port is also 27777.

    As I use the port test provided by utorrent, sometimes I get an OK, sometimes I get a closed port. (I abused the run test button)


  • LAYER 8 Global Moderator

    Ok there quite a few things going on here – with little or no understanding of some basic principles..

    First off your double natting..  So does your dsl "modem" forward traffic to your pfsense wan IP 192.168.1.10 via dmz setting or specific forwards of the ports your wanting to use?

    2nd your NAT is not linked -- why do people always undo the default setting of letting the nat create the associated firewall rule?

    3rd I would not use UPnP just setup your client to use a port, and then forward this port of pfsense.  Done!  If your dsl "modem" is correctly setup to forward this port as well.

    4th Why do you have block rfc1918 rules enabled when clearly your pfsense WAN is using a rfc1918 address -- 192.168.1.10

    5th -- So your issue is that your pings time go up when pinging google while your running torrents?  That is how internet works!!  If your using your pipe,  stuff like ping has to wait in line as that other traffic takes its turn.  Its a given your ping times are going to get higher if your using your pipe to any extent be download or upload.

    if you want specific traffic to have higher priority then your p2p traffic, then your going to have to set up QoS..  You could give icmp higher priority and in a sense let it cut in line.  But just because your internet ping times go up does not mean that you still can not use the internet.

    Set your p2p client to use say 50% of your upload and everything should still work.  Also don't double post your questions in multiple threads!



  • ^ got the feeling something went wrong from my configs. so I reset back to factory defaults (press 4 from the VM pfsense box console)

    then add the IPs as per the OP from the quote.

    added a traffic shape rule limiting to 1.5mpbs at the WAN to prevent gamers having 200ms ping.

    as for rfc1918, I believe this is blocked by default from the WAN interface wizard. should I uncheck "block private networks"? how about the "Block bogon networks"?

    finally, my initial problem is that utorrent is wrecking my internet (as evidence from ping command) and the internet will be fine if I pause / exit utorrent. after 3 minutes of monitoring ping command the problem is still here. it's different from the usual lag from heavy internet usage. the ping command will show nearly a page full of "request time out".



  • A BIG UPDATE!!!

    so I tried to temporarily exit pfsense and just directly connect this PC to the internet when I closed the shop. I was still getting that intermittent connection and I could only conclude that utorrent itself is the cause. so I downloaded a lower version of utorrent and for now everything is running fine. whatever it was that I changed in that utorrent I don't know anymore. And I guess I'll never know.

    Already tried the whole thing with pfsense back and the internet is now working as intended.



  • haven't solved anything yet.

    utorrent 1.8.5 = can't upload nor download anything (despite the number of seeds and peers). internet is fine.

    utorrent 2.2.1 = intermittent internet even if fresh downloaded only if seeds are paused. internet is fine even when downloading.

    on pfsense, I went to firewall -> rules and added 27777 port both in WAN and LAN.

    I haven't tried doing this when my pc is directly connected to the net.

    edit: I don't know why but now it's good. I probably haven't tested well enough though


  • LAYER 8 Global Moderator

    "on pfsense, I went to firewall -> rules and added 27777 port both in WAN and LAN."

    This is perfect example of lack of understanding..  So you manually created rules on your wan and lan?  What does that have to do with a forward?

    If you create NAT, there is no rule created on your lan tab.  And your nat by default will create the required rule on your WAN to all the nat.  And yet still you make no mention of pfsense being in your DMZ of your dsl "modem" or creating the forwards on your "modem"

    " it's different from the usual lag from heavy internet usage. the ping command will show nearly a page full of "request time out"."

    How is this different?  If you don't get response from your ping in the default time then it will show request timed out, even if you get an answer 1 ms latter.

    If your connection is being used - the latency of pings will increase..  This is the nature of the beast.. Did you increase the icmp timeout for your ping command?  Did you modify QoS to place higher priority on your icmp traffic or to lower your p2p traffic priority?  If not then yes its going to have an effect on your ping times - just plan that is how it works!

    You can not use your internet pipe and not expect to see changes in your latency increase in a ping..  The more you fill up your pipe, the higher the latency will go in in your ping.



  • I'm not sure how but everything is now working. and just for the record the 27777 port is still on my LAN and WAN rules.

    thanks for the support. Can close this now.


Log in to reply