Upgrade to carp and 2.1



  • Hello,

    I have a single 2.0.3 firewall here at work.  Eventually I would like to upgrade it to 2.1 AND setup a redundant/failover system.

    Do the two firewalls have to be identical?

    • I understand it would be good to at least have the same ethernet drivers, but is it necessary?

    • At the moment, they are different machines (different number of cores, and memory…

    Is it necessary to have the exact same version of pfsense?

    What would be the upgrade procedure for future upgrades?

    Thanks for your time!

    –jason



  • Do the two firewalls have to be identical?

    yes in terms of subnetting, vlans etc. No in terms of hardware.

    understand it would be good to at least have the same ethernet drivers, but is it necessary?

    Nope.

    Is it necessary to have the exact same version of pfsense?

    Nope. i stand corrected.


  • Rebel Alliance Developer Netgate

    It really is necessary to have the pfSense versions match up, otherwise you will have configuration sync and/or state sync issues.

    Otherwise, as has been stated, you don't need identical hardware or NICs, just an identical number of interfaces and to have them assigned in the exact same order on both.


Log in to reply