Ifconfig: ioctl (SIOCDIFADDR): Can't assign requested address



  • Hello:
    After upgrading to 2.1-RELEASE (i386) one of the 5 NICs firewall does not work.
    The only mistake that I see in the firewall is
      php: / interfaces.php: The command '/ sbin / ifconfig' re0 'inet delete' returned exit code '1 ', the output was' ifconfig: ioctl (SIOCDIFADDR): Can not assign requested address'
      This card should have the IP 192 168 129 254 MASK 255.255.255.0 and gateway is 192.168.129.1
    If you do a ping to the card, responds, but if you do ping the gateway, this don't respond
    Changing the settings so that you get the IP address by DHCP, the router will assign an IP 192.168.129.x and gateway 192.168.1.1, but the result is the same, you can ping the card but not the router.
    If I put a PC directly to the router, this assigns IP and you can ping the gateway and navigate Ok.



  • Just to bump this as I'm also getting this error since I plugged the wan into a new router with dhcp on the router.

    AMD64 2.1 release with openvpn.

    Nov 14 04:00:22 check_reload_status: Reloading filter
    Nov 14 04:00:22 check_reload_status: Restarting OpenVPN tunnels/interfaces
    Nov 14 04:00:22 check_reload_status: Restarting ipsec tunnels
    Nov 14 04:00:22 check_reload_status: updating dyndns WAN_DHCP
    Nov 14 04:00:03 php: rc.interfaces_wan_configure: The command '/sbin/dhclient -c /var/etc/dhclient_wan.conf msk0 > /tmp/msk0_output 2> /tmp/msk0_error_output' returned exit code '1', the output was ''
    Nov 14 04:00:03 php: rc.interfaces_wan_configure: The command '/sbin/ifconfig 'msk0' inet delete' returned exit code '1', the output was 'ifconfig: ioctl (SIOCDIFADDR): Can't assign requested address'
    Nov 14 04:00:00 check_reload_status: Configuring interface wan
    Nov 14 00:05:59 kernel: re0: promiscuous mode enabled

    Edit:
    Should add that going into the wan interface and clicking save then apply brings the nic back up again, so a sort of work around but not ideal for the hours its down until its checked and the above action carried out.

    Gonna try it without openvpn servers installed and see if that makes a difference for now as openvpn isnt essential for the next few weeks.

    Edit2
    Dont know if this is relevent
    https://groups.google.com/forum/#!msg/tunnelblick-discuss/NVJunGLxngE/EkjCRMgHfzYJ

    "2013-06-20 08:16:17 /sbin/ifconfig tun2 delete

    ifconfig: ioctl (SIOCDIFADDR): Can't assign requested address

    2013-06-20 08:16:17 NOTE: Tried to delete pre-existing tun/tap instance – No Problem if failure"