Possibly dead firebox x750e (Resolved)



  • Just a general question thrown out to the masses.

    its a bit of a long post as it details everything i've tried.

    Has anyone come upon an issue where they are unable to view the bios screen through the serial port on a Firebox.

    The reason I'm asking is that the other day i installed the LCDProc-dev package to change the display from the watchguard display to the pfsense info. I followed the instructions that i found in another post that StephenW had posted. The final step to enable the drivers was to reboot the firebox. This was duly done, as i thought a reboot would be good to clear out all the old caches at the same time. As the box had been running for the last 120 days. Normally the box would reboot in a few minutes and the fans would quieten down when WGXepc kicked in. (I can hear the fans when they are running at 100% from where i sit and know when the box is running ok once they quieten down and i cant hear them). needless to say the fans didn't quieten down after a few mins.

    Cue the further investigations of the box.
    dug out the serial cable and usb to serial adapter, and connect using Z-Term (terminal emulation program for Mac OSX) connected at 115200 8N1.
    Errors galore on the box. something about a file being required for login then the system was waiting 30secs with the word (amnesia) at the end. Cant remember the whole error msg.  :o

    thought no problem i have  a couple of spare HDD's here with PFsense already installed. just incase of events like this, (had an issue before when i done an version upgrade previously) Change the HDD over and then upload the config file i had backed up. Then the job would be done. How wrong could i be.

    Booted box and connected at 9600 8N1 to confirm the bios was seing the new HDD.

    no dice, could hear the box booting up and seen the display showing memory test passed, followed by the single beep. but still nothing on the terminal program. Needless to say a few more reboots followed to confirm what i was or wasn't seeing.

    Tried the usual.
    Replace HDD with 4Gb CF card with nano build installed.            Nothing
    Replace 4Gb CF card with original 128Mb card.                          Nothing
    Remove the HDD and CF card and boot to bios only.                Nothing
    Rest CMOS via the Jumper.                                                      Nothing
    Remove CMOS battery.                                                            Nothing
    Reset Cmos Via Jumper and remove battery.                            Nothing

    So i'm starting to think that the box is knackered.

    The only other thing i cant possibly relate to this, is that a couple of weeks ago the port that i had configured as a DMZ for an XBox 360 stopped passing data. I put that down to the port being configured on one of the OPT1 interfaces and have read in some posts that the OPT interfaces can be a bit picky at times. So i reconfigured the DMZ on to one of the MSK interfaces.

    So might be a case of pulling the OPT daughter board out of the box, just incase it has gone faulty and is pulling the rest of the box down with it. But i think that it might be clutching at straws.

    if box is fubar then i think it might mean heading over to ebay and looking for a new box. thinking maybe an XTM 5 this time.

    Anyone with any thoughts on this.



  • I have managed to track the issues down and have now got the X750e backup and running.

    It looks like the issue was that one of the memory modules that i had installed had gone faulty, (even though the memory test was been shown as ok on the front panel). After removing both the modules and booting the box, i was able to get into the bios and check the settings. replaced one module at a time to find out which one was at fault.

    box now booting of the spare HDD i had installed.

    Successfully updated to 2.1 from 2.02.

    box is quite happily running along just now.

    but may still look at getting another box and then playing about with the fail-over. May look at a SFF pc this time as easier to install PFsense if i crash the box.


  • Netgate Administrator

    Sorry I didn't get back to you earlier. Glad you tracked it down. Bad ram wasn't soemthing I would have suggested anyway.  ::)

    Steve



  • I Agree, but bad RAM does make this boxes do funny things. Just look at my last posting on pfsense on x550e.
    http://forum.pfsense.org/index.php/topic,20095.900.html


Log in to reply