2.1 on Watchguard X750e Core



  • I have followed the guides here:

    http://practicalkungfu.net/2012/02/20/how-to-install-pfsense-2-0-on-a-watchguard-x750e-core/

    and here:

    https://doc.pfsense.org/index.php/PfSense_on_Watchguard_Firebox#Serial_Port_Quirk

    I was able to get the bios upgraded and configured as directed.  I can access the bios just fine via console (115200).  However, after post, it just stops.  The bios is set to boot from HD and the first bootable HD is the CF.

    The only thing that is weird to me is that after I write the image to my SanDisk Ultra 4GB CF, it isn't accessible via My Computer in Win 7.  Should I be able to see the contents of the CF after the 2.1 image is written?  If so, why would I not be able to see it?  I used physdiskwrite to write the image.

    Any help is appreciated.


  • Netgate Administrator

    I don't know why that guide says the baud rate will be 19200, I've never seen that.
    The default console speed of pfSense is 9600. Normally if you have your serial terminal set to 115200 you will see the bios POST messages and then nothing after the console switches to 9600. If you have your serial terminal set to 9600 you see the opposite.

    The serial port quirk you linked to is only really necessary in the X-core box (X500, X700 etc) where the console becomes unusable at 9600 for some unknown reason.
    In 2.1 there is an option to set the console speed in the webgui anyway and that's much preferable. In fact it may override the loader.conf.local setting if you're using that which may explain what you're seeing.

    If you want to use one speed, 115200, to see the complete boot sequence then use the setting in the webgui; System: Advanced: Admin Access:

    You will not be able to able to read the CF card in Windows 7 after flashing it. The NanoBSD image consists of three slices (partitions) all of which are FreeBSDs UFS and not readable by Windows.

    Steve



  • Thanks for the response.  I ended up figuring it out prior to your response.  It was something with the BIOS.  I was using 750EB6.  I tried 4 with no luck and then 2.  Version 2 worked.

    However, I am now stuck in the intitial config.  I select "no" when asked if I want to set up VLANs.  It then wants me to enter a WAN interface name or a for auto-detection.  I'm not sure what it is asking here.  I entered "Comcast" for the name but it does not like this.  Auto-detection doesn't work either because there is not connection at this point.

    Any advice?


  • Netgate Administrator

    Hmm, not sure if the autodetect works on the Marvell NICs. Just enter the names manually. They are listed on the screen. The four on the left are the sk NICs, far left is sk0.
    So for example enter sk0 for WAN and sk1 for LAN.

    Steve


Log in to reply