DNS Resolving with DNS behind tunnel suddenly stopped



  • Hello!

    I've been administrating an PfSense box now for more then a month without any problems, until today. My colleagues came to me
    some hours ago and told me that they couldn't access machines behind the IPSec tunnel. After some network tests I found out that
    I could still ping the machines in question, but no DNS resolving. The DNS server used for resolving those hosts is placed behind the IPSec Tunnel aswell.

    If I did a manual lookup (bypassing the PfSense DNS forwarder and directly asked DNS server behind the tunnel) everything worked just fine.

    I tried to restart dnsmasq, didn't solve anything.

    THE SOLUTIONf was to restart the IPSec tunnel! After that everything worked as good as ever.

    Now I would like to understand why  this problem arised and how to avoid it in the future. If you have any ideas and suggestions, please share :).

    Here is the log output from racoon, http://pastebin.com/ZK9dbghW.

    Thanks.


Log in to reply