Upgrade 2.1 Results In Root Mount Error



  • Upgraded from 2.0.2 to 2.1 via gui then got the "Root Mount Error" message. At the mount prompt I entered ? and a few different items were displayed. I entered usf:\dev\ab0s1a and pfsense did load but upon a reboot root mount error returned. From reading I see that I may need to make changes to etc/fstab but not sure how or what I would need to change. amd64 on a HDD (was AHCI switch to IDE due to another post). CAn someone point me in the right direction


  • Netgate Administrator

    Yes as you have found you need to edit the fstab to mount the / and swap partitions from the correct location. Also as you found the AHCI handling changed between 2.0.X and 2.1. 2.1 is able to see more hardware which can change the apparent mount locations.

    What does your current fstab look like? You can list it at the console with 'cat /etc/fstab'. You can probably also run that in Diagnostics: Command Prompt:

    You can edit it in Diagnostics: Edit File:

    Steve


Log in to reply