Possible issues with ALIX 2D3/2D13 kit



  • About a week back I ordered "ALIX.2D3 / 2D13 Kit" (http://store.netgate.com/ALIX2D3-2D13-Kit-Black-Unassembled-P172C82.aspx) from Netgate and I ran into couple issues as follows:

    over the weekend but I ran into two issues:

    1. After installing pfSense v2.1, while configuring interfaces, the pfSense installation would not identify the OPT1 interface.  One of the lights on the port/interface would always be yellow.  When I would connect ethernet cable to the port the other light would block couple times and would become a steady yellow.
      I tried different ethernet cables and different client PCs but the pfSense installation was never able to identify a connection over the port and would not be able configure the interface.

    2. I was not able to screw the upper metallic cover of the kit to the bottom part. I found that the bottom portion screw holes don't have threads and so the black screws would never fit in there.

    I was wondering if anyone else has run into these issues and/or has any suggestions to fix them.

    Any help is greatly appreciated.  Thanks!


  • Netgate Administrator

    I would get back to Netgate about that. There are many many people here running that kit without any issues.

    Steve



  • hi Steve,

    Did you hear from Netgate?

    Netgate replied me last week saying they are shipping pfSense v2.0.3 and are testing v2.1.  However one of my colleagues was able to get v2.1 to run fine - with all interfaces recorgnized and working - just fine.

    And there must be others out there who have tried v2.1 on ALIX 2D/2D13 kit and know whether it works or not - with all interfaces.

    What is the experience of others with pfSense v2.1 on ALIX 2D/2D13 and all interfaces?

    Thanks,
    Kamalesh



  • just to confirm: Upgraded from 2.0.3 to 2.1 on my Alix 2D13 @home since a couple of weeks. 0 issues…

    Given your description, I would suspect a HW issue?

    As your system is up&running, when you go to https://yourIPgoesHere/status.php#sysctl

    It reports in one of the first sections with interfaces info, and this is partial output if my Alix:

    
    vr2: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
    	options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:0d:bb:bb:dd:cc
    	inet6 fe00::00d:bbff:ffbb:aaaa%vr2 prefixlen 64 scopeid 0x3
    	nd6 options=1 <performnud>media: Ethernet autoselect</performnud></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></broadcast,simplex,multicast> 
    

    I have assigned the interface but did not configure it.
    (I do not use the 3rd interface, though it is properly detected, an I am able to select and configure it… just tested it remotely)

    Did you test with a 2.0 version? Not sure if it's worth the effort, you might be better off by just claiming warranty...


  • Netgate Administrator

    @kayp2715:

    hi Steve,

    Did you hear from Netgate?

    Sorry, I was suggesting that you contact Netgate directly. I am not associated with them at all, I've never purchased anything from them.
    I know that there are a lot of users here running that same board under 2.1 with no issues. Some people had problems upgrading from 2.0.3 due to the low memory but a fresh install should be no problem.
    I agree it sounds like it might be a hardware fault if it's not detected at all.

    Steve



  • Thanks for your reply bennyc.  Here is the output for my pfSense installation on the ALIX board.  I have edited some portions of the output.

    vr0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=8280b<rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>vr0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether <ether>inet 192.168.a.b netmask 0xffffff00 broadcast 192.168.a.z
    inet6 fe80::1:1%vr0 prefixlen 64 scopeid 0x1
    nd6 options=1 <performnud>media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    vr1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether <ether>inet a.b.c.d netmask 0xfffff800 broadcast 255.255.255.255
    inet6 f::g:h:i:j%vr1 prefixlen 64 scopeid 0x2
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    vr2: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
    options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether <ether>media: Ethernet autoselect
    enc0: flags=0<> metric 0 mtu 1536
    pfsync0: flags=0<> metric 0 mtu 1460
    syncpeer: 224.0.0.240 maxupd: 128 syncok: 1
    pflog0: flags=100 <promisc>metric 0 mtu 33192
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x7
    nd6 options=3 <performnud,accept_rtadv>ether <ether>inet 192.168.a.b netmask 0xffffff00 broadcast 192.168.a.z
    inet6 fe80::1:1%vr0 prefixlen 64 scopeid 0x1
    nd6 options=1 <performnud>media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    vr1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether <ether>inet a.b.c.d netmask 0xfffff800 broadcast 255.255.255.255
    inet6 f::g:h:i:j%vr1 prefixlen 64 scopeid 0x2
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    vr2: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
    options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether <ether>media: Ethernet autoselect
    enc0: flags=0<> metric 0 mtu 1536
    pfsync0: flags=0<> metric 0 mtu 1460
    syncpeer: 224.0.0.240 maxupd: 128 syncok: 1
    pflog0: flags=100 <promisc>metric 0 mtu 33192
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x7
    nd6 options=3 <performnud,accept_rtadv>vr0 and vr1 have been configured.  I was not able to get pfSense to recognize and use the OPT1 interface which I believe is represented by vr2 here.
    And it appears like pfSense know about the interface,

    Steve,

    Sorry, my bad. I see what you meant there.

    I heard back from Netgate today and they said

    1. Try pfSense v2.0.3
    2. Just jam the screws in the chassis holes and they will just create threads in there

    I would appreciate of if anyone else has tried out the ALIX 2D13 boad and has some additional insight.

    Thanks again guys.</performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></promisc></ether></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></broadcast,simplex,multicast></full-duplex></performnud,accept_rtadv></ether></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud></ether></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></promisc></ether></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></broadcast,simplex,multicast></full-duplex></performnud,accept_rtadv></ether></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud></ether></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast>


  • Netgate Administrator

    Hmm, it certainly looks like it's seeing vr2 correctly. Do you have any logs from immediately after you tried to enable it or connect something to it? What exactly have you tried connecting to it? Have you tried a switch?

    I've not seen one those kits so I can't really comment on the screws but if they're self tapping then that might make sense. Though they would not normally be used in that situation since you can easily damage the thread when re-inserting them.

    Steve



  • Good thing it is recognized, but that doesn't mean yet it will work properly if you have a hw issue.
    If you connect something to it (switch or pc), do the flags change? (8802<broadcast,simplex,multicast>) -> status UP, RUNNING, …?
    If it doesn't change, it might be the driver is unable to get correct info from that adapter. And as those are 3 identical adapters onboard, I think it is unlikely it will be a driver issue.
    The more I read your post the more I get the feeling you just got a lemon. Unless you have much time for tinkering, I would focus on what netgear advises to test, so you can send it back & claim warranty, and request another one...

    note: as I have a 2D13 myself, I will test this evening if I can get that port up & running, just to rule out any doubts...  :-\ but I am pretty confident it ain't a pfSense 2.1 issue.</broadcast,simplex,multicast>



  • It took a day longer until I had some spare time to test, but the results are as predicted.
    I plugged it into my switch, and my leds behave normal, and blink during activity on the link.

    I also saw following events in my system\general log:

    Oct 23 20:11:41	php: rc.newwanip: rc.newwanip: on (IP address: ) (interface: opt2) (real interface: vr2).
    Oct 23 20:11:41	php: rc.newwanip: rc.newwanip: Informational is starting vr2.
    Oct 23 18:11:27	check_reload_status: rc.newwanip starting vr2
    Oct 23 20:11:27	php: rc.linkup: Hotplug event detected for OPT2(opt2) but ignoring since interface is configured with static IP ( )
    

    Assinging the interface does not change any status.
    However,as soon as I enable the interface (even without ipv4 or ipv6 configuration), the status becomes as a following on my Alix :

    vr2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500</up,broadcast,running,simplex,multicast>
    

    -> it added UP & RUNNING, and changed the flags number.

    I think it's pretty safe to conclude that it is not the combination of a 2D13 OPT interface and v2.1.
    Most probably my efforts did not help that much (as you're still stuck with 2/3rd firewall  ;D), but at least now you know  ;)



  • Thanks for the follow up bennyc.

    I assigned enabled and configured the interface OPT1 and here is what I see on the /status.php#sysctl page

    
    vr0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether ====
    	inet 192.168.a.b netmask 0xffffff00 broadcast 192.168.7.255
    	inet6 ====%vr0 prefixlen 64 scopeid 0x1
    	nd6 options=1 <performnud>media: Ethernet autoselect (100baseTX <full-duplex>)
    	status: active
    vr1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether ====
    	inet ==== netmask 0xfffff800 broadcast 255.255.255.255
    	inet6 ====%vr1 prefixlen 64 scopeid 0x2
    	nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
    	status: active
    vr2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether ====
    	inet 192.168.p.q netmask 0xffffff00 broadcast 192.168.8.255
    	inet6 ====%vr2 prefixlen 64 scopeid 0x3
    	nd6 options=1 <performnud>media: Ethernet autoselect (100baseTX <full-duplex>)
    	status: active
    enc0: flags=0<> metric 0 mtu 1536
    pfsync0: flags=0<> metric 0 mtu 1460
    	syncpeer: 224.0.0.240 maxupd: 128 syncok: 1
    pflog0: flags=100 <promisc>metric 0 mtu 33192
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    	options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000
    	inet6 ::1 prefixlen 128
    	inet6 =::1%lo0 prefixlen 64 scopeid 0x7
    	nd6 options=3 <performnud,accept_rtadv></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></promisc></full-duplex></performnud></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast> 
    

    I opened up a terminal and connected to the ALIX board and here is what I see on the console/screen

    FreeBSD/i386 (pfsense.localdomain) (console)

    
    *** Welcome to pfSense 2.1-RELEASE-nanobsd (i386) on pfsense ***
    
     WAN (wan)       -> vr1        -> v4/DHCP4: ====/21
     LAN (lan)       -> vr0        -> v4: 192.168.a.b/24
     OPT1 (opt1)     -> vr2        -> v4: 192.168.p.q/24
    
    

    Encouraged, I connected 2 different PCs to the OPT1 interface but I still don't get/see any connection from the interface.  The PCs continue to do the "trying to connect/ identifying network" thing but they never see a connection.  They don't get an IP address.

    What can I do next?  Where can I see the logs on the system itself?



  • So I looked around a bit and it turns out I had to enable DHCP Server for the OPT1 interface.  Duh, right?

    Anyways, so clients are getting IP addresses now but not able to go out to the internet. pinging 8.8.8.8 is timing out and tracert to 8.8.8.8 is timing out as well.

    I'll keep looking around and keep you guys posted.  But if there anything obvious that I may have missed please let me know.

    Thanks!



  • Ok, didn't see that one coming, "duh" for me too  ???

    The rest should be more straight-forward. When you add a new interface, by default there aren't any rules so no traffic is allowed. Go to the Firewall\rules, you should see something like this:

    No rules are currently defined for this interface
    All incoming connections on this interface will be blocked until you add pass rules.

    Take a peek on your other LAN adapter rules, make a similar rule but for the OPT interface. (or whatever you want to do with this second interface)
    That should do the trick  ;)


  • Netgate Administrator

    Yep exactly, just add appropriate firewall rule(s) for your needs.
    Looks like it's working as expected.  :)

    Steve



  • Yes, I added rules on both LAN and OPT1 interfaces on that day and I was/am all set.

    Thanks to both of you - stephenw10 and bennyc.

    I checked with my colleague and he said that he too was not able to get the OPT1 interface to configure from command line and he got it working from the web interface only.

    We as a community need to better test that option.


Log in to reply